USN-6864-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6864-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6864-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6864-1
Related
  • CVE-2024-21823
  • CVE-2024-26924
Published
2024-07-03T16:05:35.846410Z
Modified
2024-07-04T02:21:18.974320Z
Summary
linux-gcp, linux-intel vulnerabilities
Details

It was discovered that the Intel Data Streaming and Intel Analytics Accelerator drivers in the Linux kernel allowed direct access to the devices for unprivileged users and virtual machines. A local attacker could use this to cause a denial of service. (CVE-2024-21823)

A security issue was discovered in the Linux kernel. An attacker could possibly use it to compromise the system. This update corrects flaws in the following subsystem: - Netfilter; (CVE-2024-26924)

References

Affected packages

Ubuntu:24.04:LTS / linux-gcp

Package

Name
linux-gcp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.8.0-1009.10

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-gcp": "6.8.0-1009.10",
            "linux-image-6.8.0-1009-gcp": "6.8.0-1009.10",
            "linux-modules-iwlwifi-gcp": "6.8.0-1009.10",
            "linux-modules-6.8.0-1009-gcp": "6.8.0-1009.10",
            "linux-headers-6.8.0-1009-gcp": "6.8.0-1009.10",
            "linux-gcp": "6.8.0-1009.10",
            "linux-gcp-headers-6.8.0-1009": "6.8.0-1009.10",
            "linux-gcp-tools-6.8.0-1009": "6.8.0-1009.10",
            "linux-image-gcp": "6.8.0-1009.10",
            "linux-image-unsigned-6.8.0-1009-gcp": "6.8.0-1009.10",
            "linux-modules-extra-6.8.0-1009-gcp": "6.8.0-1009.10",
            "linux-modules-extra-gcp": "6.8.0-1009.10",
            "linux-buildinfo-6.8.0-1009-gcp": "6.8.0-1009.10",
            "linux-tools-6.8.0-1009-gcp": "6.8.0-1009.10",
            "linux-modules-iwlwifi-6.8.0-1009-gcp": "6.8.0-1009.10",
            "linux-headers-gcp": "6.8.0-1009.10"
        }
    ]
}

Ubuntu:24.04:LTS / linux-intel

Package

Name
linux-intel

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.8.0-1006.13

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-intel": "6.8.0-1006.13",
            "linux-intel": "6.8.0-1006.13",
            "linux-image-unsigned-6.8.0-1006-intel": "6.8.0-1006.13",
            "linux-cloud-tools-6.8.0-1006-intel": "6.8.0-1006.13",
            "linux-image-intel": "6.8.0-1006.13",
            "linux-tools-6.8.0-1006-intel": "6.8.0-1006.13",
            "linux-modules-extra-6.8.0-1006-intel": "6.8.0-1006.13",
            "linux-headers-6.8.0-1006-intel": "6.8.0-1006.13",
            "linux-tools-intel": "6.8.0-1006.13",
            "linux-buildinfo-6.8.0-1006-intel": "6.8.0-1006.13",
            "linux-intel-tools-6.8.0-1006": "6.8.0-1006.13",
            "linux-image-6.8.0-1006-intel": "6.8.0-1006.13",
            "linux-modules-extra-intel": "6.8.0-1006.13",
            "linux-intel-cloud-tools-6.8.0-1006": "6.8.0-1006.13",
            "linux-intel-headers-6.8.0-1006": "6.8.0-1006.13",
            "linux-modules-iwlwifi-intel": "6.8.0-1006.13",
            "linux-modules-6.8.0-1006-intel": "6.8.0-1006.13",
            "linux-modules-iwlwifi-6.8.0-1006-intel": "6.8.0-1006.13"
        }
    ]
}