USN-6881-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6881-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6881-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6881-1
Related
Published
2024-07-08T09:37:45.896446Z
Modified
2024-07-08T09:37:45.896446Z
Summary
exim4 vulnerability
Details

It was discovered that Exim did not enforce STARTTLS sync point on client side. An attacker could possibly use this issue to perform response injection during MTA SMTP sending.

References

Affected packages

Ubuntu:Pro:18.04:LTS / exim4

Package

Name
exim4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.90.1-1ubuntu1.10+esm4

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "exim4": "4.90.1-1ubuntu1.10+esm4",
            "exim4-daemon-light": "4.90.1-1ubuntu1.10+esm4",
            "exim4-config": "4.90.1-1ubuntu1.10+esm4",
            "exim4-base": "4.90.1-1ubuntu1.10+esm4",
            "eximon4": "4.90.1-1ubuntu1.10+esm4",
            "exim4-dev": "4.90.1-1ubuntu1.10+esm4",
            "exim4-daemon-heavy": "4.90.1-1ubuntu1.10+esm4"
        }
    ]
}

Ubuntu:20.04:LTS / exim4

Package

Name
exim4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.93-13ubuntu1.11

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "exim4": "4.93-13ubuntu1.11",
            "exim4-daemon-light": "4.93-13ubuntu1.11",
            "exim4-config": "4.93-13ubuntu1.11",
            "exim4-base": "4.93-13ubuntu1.11",
            "eximon4": "4.93-13ubuntu1.11",
            "exim4-dev": "4.93-13ubuntu1.11",
            "exim4-daemon-heavy": "4.93-13ubuntu1.11"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / exim4

Package

Name
exim4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.82-3ubuntu2.4+esm8

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "exim4": "4.82-3ubuntu2.4+esm8",
            "exim4-daemon-light": "4.82-3ubuntu2.4+esm8",
            "exim4-config": "4.82-3ubuntu2.4+esm8",
            "exim4-base": "4.82-3ubuntu2.4+esm8",
            "eximon4": "4.82-3ubuntu2.4+esm8",
            "exim4-dev": "4.82-3ubuntu2.4+esm8",
            "exim4-daemon-heavy": "4.82-3ubuntu2.4+esm8"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / exim4

Package

Name
exim4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.86.2-2ubuntu2.6+esm7

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "exim4": "4.86.2-2ubuntu2.6+esm7",
            "exim4-daemon-light": "4.86.2-2ubuntu2.6+esm7",
            "exim4-config": "4.86.2-2ubuntu2.6+esm7",
            "exim4-base": "4.86.2-2ubuntu2.6+esm7",
            "eximon4": "4.86.2-2ubuntu2.6+esm7",
            "exim4-dev": "4.86.2-2ubuntu2.6+esm7",
            "exim4-daemon-heavy": "4.86.2-2ubuntu2.6+esm7"
        }
    ]
}