USN-6884-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6884-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6884-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6884-1
Related
  • CVE-2024-32498
Published
2024-07-08T11:59:21.922467Z
Modified
2024-07-08T11:59:21.922467Z
Summary
nova vulnerability
Details

Martin Kaesberger discovered that Nova incorrectly handled QCOW2 image processing. An authenticated user could use this issue to access arbitrary files on the server, possibly exposing sensitive information.

References

Affected packages

Ubuntu:20.04:LTS / nova

Package

Name
nova

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:21.2.4-0ubuntu2.8

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "nova-compute-lxc": "2:21.2.4-0ubuntu2.8",
            "nova-volume": "2:21.2.4-0ubuntu2.8",
            "nova-doc": "2:21.2.4-0ubuntu2.8",
            "nova-novncproxy": "2:21.2.4-0ubuntu2.8",
            "nova-api-os-compute": "2:21.2.4-0ubuntu2.8",
            "nova-compute-kvm": "2:21.2.4-0ubuntu2.8",
            "nova-ajax-console-proxy": "2:21.2.4-0ubuntu2.8",
            "nova-spiceproxy": "2:21.2.4-0ubuntu2.8",
            "nova-compute-vmware": "2:21.2.4-0ubuntu2.8",
            "nova-compute-xen": "2:21.2.4-0ubuntu2.8",
            "nova-scheduler": "2:21.2.4-0ubuntu2.8",
            "nova-conductor": "2:21.2.4-0ubuntu2.8",
            "nova-compute": "2:21.2.4-0ubuntu2.8",
            "python3-nova": "2:21.2.4-0ubuntu2.8",
            "nova-serialproxy": "2:21.2.4-0ubuntu2.8",
            "nova-api-metadata": "2:21.2.4-0ubuntu2.8",
            "nova-compute-qemu": "2:21.2.4-0ubuntu2.8",
            "nova-api": "2:21.2.4-0ubuntu2.8",
            "nova-api-os-volume": "2:21.2.4-0ubuntu2.8",
            "nova-common": "2:21.2.4-0ubuntu2.8",
            "nova-compute-libvirt": "2:21.2.4-0ubuntu2.8",
            "nova-cells": "2:21.2.4-0ubuntu2.8"
        }
    ]
}

Ubuntu:22.04:LTS / nova

Package

Name
nova

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3:25.2.1-0ubuntu2.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "nova-compute-lxc": "3:25.2.1-0ubuntu2.3",
            "nova-volume": "3:25.2.1-0ubuntu2.3",
            "nova-doc": "3:25.2.1-0ubuntu2.3",
            "nova-novncproxy": "3:25.2.1-0ubuntu2.3",
            "nova-api-os-compute": "3:25.2.1-0ubuntu2.3",
            "nova-compute-kvm": "3:25.2.1-0ubuntu2.3",
            "nova-compute-ironic": "3:25.2.1-0ubuntu2.3",
            "nova-ajax-console-proxy": "3:25.2.1-0ubuntu2.3",
            "nova-spiceproxy": "3:25.2.1-0ubuntu2.3",
            "nova-compute-vmware": "3:25.2.1-0ubuntu2.3",
            "nova-compute-xen": "3:25.2.1-0ubuntu2.3",
            "nova-scheduler": "3:25.2.1-0ubuntu2.3",
            "nova-conductor": "3:25.2.1-0ubuntu2.3",
            "nova-compute": "3:25.2.1-0ubuntu2.3",
            "python3-nova": "3:25.2.1-0ubuntu2.3",
            "nova-serialproxy": "3:25.2.1-0ubuntu2.3",
            "nova-api-metadata": "3:25.2.1-0ubuntu2.3",
            "nova-compute-qemu": "3:25.2.1-0ubuntu2.3",
            "nova-api": "3:25.2.1-0ubuntu2.3",
            "nova-api-os-volume": "3:25.2.1-0ubuntu2.3",
            "nova-common": "3:25.2.1-0ubuntu2.3",
            "nova-compute-libvirt": "3:25.2.1-0ubuntu2.3",
            "nova-cells": "3:25.2.1-0ubuntu2.3"
        }
    ]
}

Ubuntu:23.10 / nova

Package

Name
nova

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3:28.0.1-0ubuntu1.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "nova-compute-lxc": "3:28.0.1-0ubuntu1.3",
            "nova-volume": "3:28.0.1-0ubuntu1.3",
            "nova-doc": "3:28.0.1-0ubuntu1.3",
            "nova-novncproxy": "3:28.0.1-0ubuntu1.3",
            "nova-api-os-compute": "3:28.0.1-0ubuntu1.3",
            "nova-compute-kvm": "3:28.0.1-0ubuntu1.3",
            "nova-compute-ironic": "3:28.0.1-0ubuntu1.3",
            "nova-ajax-console-proxy": "3:28.0.1-0ubuntu1.3",
            "nova-spiceproxy": "3:28.0.1-0ubuntu1.3",
            "nova-compute-vmware": "3:28.0.1-0ubuntu1.3",
            "nova-compute-xen": "3:28.0.1-0ubuntu1.3",
            "nova-scheduler": "3:28.0.1-0ubuntu1.3",
            "nova-conductor": "3:28.0.1-0ubuntu1.3",
            "nova-compute": "3:28.0.1-0ubuntu1.3",
            "python3-nova": "3:28.0.1-0ubuntu1.3",
            "nova-serialproxy": "3:28.0.1-0ubuntu1.3",
            "nova-api-metadata": "3:28.0.1-0ubuntu1.3",
            "nova-compute-qemu": "3:28.0.1-0ubuntu1.3",
            "nova-api": "3:28.0.1-0ubuntu1.3",
            "nova-api-os-volume": "3:28.0.1-0ubuntu1.3",
            "nova-common": "3:28.0.1-0ubuntu1.3",
            "nova-compute-libvirt": "3:28.0.1-0ubuntu1.3",
            "nova-cells": "3:28.0.1-0ubuntu1.3"
        }
    ]
}

Ubuntu:24.04:LTS / nova

Package

Name
nova

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3:29.0.1-0ubuntu1.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "nova-compute-lxc": "3:29.0.1-0ubuntu1.3",
            "nova-volume": "3:29.0.1-0ubuntu1.3",
            "nova-doc": "3:29.0.1-0ubuntu1.3",
            "nova-novncproxy": "3:29.0.1-0ubuntu1.3",
            "nova-api-os-compute": "3:29.0.1-0ubuntu1.3",
            "nova-compute-kvm": "3:29.0.1-0ubuntu1.3",
            "nova-compute-ironic": "3:29.0.1-0ubuntu1.3",
            "nova-ajax-console-proxy": "3:29.0.1-0ubuntu1.3",
            "nova-spiceproxy": "3:29.0.1-0ubuntu1.3",
            "nova-compute-vmware": "3:29.0.1-0ubuntu1.3",
            "nova-compute-xen": "3:29.0.1-0ubuntu1.3",
            "nova-scheduler": "3:29.0.1-0ubuntu1.3",
            "nova-conductor": "3:29.0.1-0ubuntu1.3",
            "nova-compute": "3:29.0.1-0ubuntu1.3",
            "python3-nova": "3:29.0.1-0ubuntu1.3",
            "nova-serialproxy": "3:29.0.1-0ubuntu1.3",
            "nova-api-metadata": "3:29.0.1-0ubuntu1.3",
            "nova-compute-qemu": "3:29.0.1-0ubuntu1.3",
            "nova-api": "3:29.0.1-0ubuntu1.3",
            "nova-api-os-volume": "3:29.0.1-0ubuntu1.3",
            "nova-common": "3:29.0.1-0ubuntu1.3",
            "nova-compute-libvirt": "3:29.0.1-0ubuntu1.3",
            "nova-cells": "3:29.0.1-0ubuntu1.3"
        }
    ]
}