UVI-2021-1000928

Source
https://github.com/cloudsecurityalliance/gsd-database/blob/main/2021/1000xxx/UVI-2021-1000928.json
Published
2021-06-30T00:25:06.253215Z
Modified
2021-10-14T18:58:30.287933Z
Details

can: j1939: fix Use-after-Free, hold skb ref while in use

This is an automated ID intended to aid in discovery of potential security vulnerabilities. The actual impact and attack plausibility have not yet been proven. This ID is fixed in Linux Kernel version v5.4.128 by commit 22cba878abf646cd3a02ee7c8c2cef7afe66a256, it was introduced in version v5.4 by commit 9d71dd0c70099914fcd063135da3c580865e924c. For more details please see the references link.

References

Affected packages

Linux / Kernel

Kernel

Affected ranges

Type
GIT
Events
Introduced
9d71dd0c70099914fcd063135da3c580865e924c
Limit
22cba878abf646cd3a02ee7c8c2cef7afe66a256

Affected versions

v5.*

v5.3
v5.3-rc8
v5.4
v5.4-rc1
v5.4-rc2
v5.4-rc3
v5.4-rc4
v5.4-rc5
v5.4-rc6
v5.4-rc7
v5.4-rc8
v5.4.1
v5.4.10
v5.4.100
v5.4.101
v5.4.102
v5.4.103
v5.4.104
v5.4.105
v5.4.106
v5.4.107
v5.4.108
v5.4.109
v5.4.11
v5.4.110
v5.4.111
v5.4.112
v5.4.113
v5.4.114
v5.4.115
v5.4.116
v5.4.117
v5.4.118
v5.4.119
v5.4.12
v5.4.120
v5.4.121
v5.4.122
v5.4.123
v5.4.124
v5.4.125
v5.4.126
v5.4.127
v5.4.13
v5.4.14
v5.4.15
v5.4.16
v5.4.17
v5.4.18
v5.4.19
v5.4.2
v5.4.20
v5.4.21
v5.4.22
v5.4.23
v5.4.24
v5.4.25
v5.4.26
v5.4.27
v5.4.28
v5.4.29
v5.4.3
v5.4.30
v5.4.31
v5.4.32
v5.4.33
v5.4.34
v5.4.35
v5.4.36
v5.4.37
v5.4.38
v5.4.39
v5.4.4
v5.4.40
v5.4.41
v5.4.42
v5.4.43
v5.4.44
v5.4.45
v5.4.46
v5.4.47
v5.4.48
v5.4.49
v5.4.5
v5.4.50
v5.4.51
v5.4.52
v5.4.53
v5.4.54
v5.4.55
v5.4.56
v5.4.57
v5.4.58
v5.4.59
v5.4.6
v5.4.60
v5.4.61
v5.4.62
v5.4.63
v5.4.64
v5.4.65
v5.4.66
v5.4.67
v5.4.68
v5.4.69
v5.4.7
v5.4.70
v5.4.71
v5.4.72
v5.4.73
v5.4.74
v5.4.75
v5.4.76
v5.4.77
v5.4.78
v5.4.79
v5.4.8
v5.4.80
v5.4.81
v5.4.82
v5.4.83
v5.4.84
v5.4.85
v5.4.86
v5.4.87
v5.4.88
v5.4.89
v5.4.9
v5.4.90
v5.4.91
v5.4.92
v5.4.93
v5.4.94
v5.4.95
v5.4.96
v5.4.97
v5.4.98
v5.4.99