USN-2256-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-2256-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-2256-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-2256-1
Related
  • CVE-2014-3497
Published
2014-06-25T21:54:35.531193Z
Modified
2014-06-25T21:54:35.531193Z
Summary
swift vulnerability
Details

John Dickinson discovered that Swift did not properly quote the WWW-Authenticate header value. If a user were tricked into navigating to a malicious Swift URL, an attacker could conduct cross-site scripting attacks. With cross-site scripting vulnerabilities, if a user were tricked into viewing server output during a crafted server request, a remote attacker could exploit this to modify the contents, or steal confidential data, within the same domain.

References

Affected packages

Ubuntu:14.04:LTS / swift

Package

Name
swift

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.13.1-0ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "swift-object": "1.13.1-0ubuntu1.1",
            "swift-proxy": "1.13.1-0ubuntu1.1",
            "swift-object-expirer": "1.13.1-0ubuntu1.1",
            "swift-account": "1.13.1-0ubuntu1.1",
            "swift-container": "1.13.1-0ubuntu1.1",
            "python-swift": "1.13.1-0ubuntu1.1",
            "swift-doc": "1.13.1-0ubuntu1.1",
            "swift": "1.13.1-0ubuntu1.1"
        }
    ]
}