USN-2327-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-2327-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-2327-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-2327-1
Related
  • CVE-2014-3609
Published
2014-08-28T03:31:45.331533Z
Modified
2014-08-28T03:31:45.331533Z
Summary
squid3 vulnerability
Details

Matthew Daley discovered that Squid 3 did not properly perform input validation in request parsing. A remote attacker could send crafted Range requests to cause a denial of service.

References

Affected packages

Ubuntu:14.04:LTS / squid3

Package

Name
squid3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.3.8-1ubuntu6.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "squid": "3.3.8-1ubuntu6.1",
            "squid3-common": "3.3.8-1ubuntu6.1",
            "squid-purge": "3.3.8-1ubuntu6.1",
            "squid3": "3.3.8-1ubuntu6.1",
            "squid-cgi": "3.3.8-1ubuntu6.1",
            "squidclient": "3.3.8-1ubuntu6.1"
        }
    ]
}