USN-2450-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-2450-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-2450-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-2450-1
Related
  • CVE-2014-9221
Published
2015-01-05T13:19:04.751942Z
Modified
2015-01-05T13:19:04.751942Z
Summary
strongswan vulnerability
Details

Mike Daskalakis discovered that strongSwan incorrectly handled IKEv2 payloads that contained the Diffie-Hellman group 1025. A remote attacker could use this issue to cause the IKE daemon to crash, resulting in a denial of service.

References

Affected packages

Ubuntu:14.04:LTS / strongswan

Package

Name
strongswan

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.1.2-0ubuntu2.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "strongswan-plugin-attr-sql": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-radattr": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-simaka-sql": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-sim-file": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-systime-fix": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-sim": "5.1.2-0ubuntu2.2",
            "strongswan-tnc-server": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-led": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-simaka-pseudonym": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-tls": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-coupling": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-xauth-noauth": "5.1.2-0ubuntu2.2",
            "strongswan-ikev1": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-sshkey": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-aka": "5.1.2-0ubuntu2.2",
            "strongswan-tnc-client": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-unity": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-mysql": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-ttls": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-dynamic": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-gcrypt": "5.1.2-0ubuntu2.2",
            "strongswan-tnc-base": "5.1.2-0ubuntu2.2",
            "libstrongswan": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-ldap": "5.1.2-0ubuntu2.2",
            "strongswan-tnc-pdp": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-sqlite": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-xauth-generic": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-simaka-reauth": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-md5": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-duplicheck": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-af-alg": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-error-notify": "5.1.2-0ubuntu2.2",
            "strongswan-starter": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-radius": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-tnc": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-fips-prf": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-gtc": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-load-tester": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-certexpire": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-kernel-libipsec": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-xauth-pam": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-soup": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-dhcp": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-ipseckey": "5.1.2-0ubuntu2.2",
            "strongswan-nm": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-farp": "5.1.2-0ubuntu2.2",
            "strongswan-ikev2": "5.1.2-0ubuntu2.2",
            "strongswan": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-whitelist": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-pkcs11": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-ntru": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-agent": "5.1.2-0ubuntu2.2",
            "strongswan-ike": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-openssl": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-gmp": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-dnskey": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-peap": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-sim-pcsc": "5.1.2-0ubuntu2.2",
            "strongswan-tnc-ifmap": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-pgp": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-xauth-eap": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-aka-3gpp2": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-sql": "5.1.2-0ubuntu2.2",
            "strongswan-pt-tls-client": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-eap-mschapv2": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-pubkey": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-dnscert": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-lookip": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-curl": "5.1.2-0ubuntu2.2",
            "strongswan-plugin-unbound": "5.1.2-0ubuntu2.2"
        }
    ]
}