USN-2474-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-2474-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-2474-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-2474-1
Related
  • CVE-2014-8150
Published
2015-01-15T13:24:40.928336Z
Modified
2015-01-15T13:24:40.928336Z
Summary
curl vulnerability
Details

Andrey Labunets discovered that curl incorrectly handled certain URLs when using a proxy server. If a user or automated system were tricked into using a specially crafted URL, an attacker could possibly use this issue to inject arbitrary HTTP requests.

References

Affected packages

Ubuntu:14.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.35.0-1ubuntu2.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "curl-udeb": "7.35.0-1ubuntu2.3",
            "libcurl3-udeb": "7.35.0-1ubuntu2.3",
            "curl": "7.35.0-1ubuntu2.3",
            "libcurl3": "7.35.0-1ubuntu2.3",
            "libcurl4-gnutls-dev": "7.35.0-1ubuntu2.3",
            "libcurl3-gnutls": "7.35.0-1ubuntu2.3",
            "libcurl4-doc": "7.35.0-1ubuntu2.3",
            "libcurl3-nss": "7.35.0-1ubuntu2.3",
            "libcurl4-nss-dev": "7.35.0-1ubuntu2.3",
            "libcurl4-openssl-dev": "7.35.0-1ubuntu2.3"
        }
    ]
}