USN-2495-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-2495-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-2495-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-2495-1
Related
  • CVE-2015-1209
  • CVE-2015-1210
  • CVE-2015-1211
  • CVE-2015-1212
Published
2015-02-10T17:56:21.018082Z
Modified
2015-02-10T17:56:21.018082Z
Summary
oxide-qt vulnerabilities
Details

A use-after-free bug was discovered in the DOM implementation in Blink. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to cause a denial of service via renderer crash or execute arbitrary code with the privileges of the sandboxed render process. (CVE-2015-1209)

It was discovered that V8 did not properly consider frame access restrictions when throwing exceptions in some circumstances. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to bypass same origin restrictions. (CVE-2015-1210)

It was discovered that Chromium did not properly restrict the URI scheme during ServiceWorker registration. If a user were tricked in to downloading and opening a specially crafted HTML file, an attacker could potentially exploit this to bypass security restrictions. (CVE-2015-1211)

Multiple security issues were discovered in Chromium. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit these to read uninitialized memory, cause a denial of service via application crash or execute arbitrary code with the privileges of the user invoking the program. (CVE-2015-1212)

References

Affected packages

Ubuntu:14.04:LTS / oxide-qt

Package

Name
oxide-qt

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.4.3-0ubuntu0.14.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "oxideqt-chromedriver": "1.4.3-0ubuntu0.14.04.1",
            "oxideqt-codecs-extra": "1.4.3-0ubuntu0.14.04.1",
            "liboxideqt-qmlplugin": "1.4.3-0ubuntu0.14.04.1",
            "oxideqmlscene": "1.4.3-0ubuntu0.14.04.1",
            "oxideqt-codecs": "1.4.3-0ubuntu0.14.04.1",
            "liboxideqtquick0": "1.4.3-0ubuntu0.14.04.1",
            "liboxideqtcore0": "1.4.3-0ubuntu0.14.04.1"
        }
    ]
}