USN-2510-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-2510-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-2510-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-2510-1
Related
  • CVE-2014-9656
  • CVE-2014-9657
  • CVE-2014-9658
  • CVE-2014-9659
  • CVE-2014-9660
  • CVE-2014-9661
  • CVE-2014-9662
  • CVE-2014-9663
  • CVE-2014-9664
  • CVE-2014-9665
  • CVE-2014-9666
  • CVE-2014-9667
  • CVE-2014-9668
  • CVE-2014-9669
  • CVE-2014-9670
  • CVE-2014-9671
  • CVE-2014-9672
  • CVE-2014-9673
  • CVE-2014-9674
  • CVE-2014-9675
Published
2015-02-24T19:33:21.659909Z
Modified
2015-02-24T19:33:21.659909Z
Summary
freetype vulnerabilities
Details

Mateusz Jurczyk discovered that FreeType did not correctly handle certain malformed font files. If a user were tricked into using a specially crafted font file, a remote attacker could cause FreeType to crash or possibly execute arbitrary code with user privileges.

References

Affected packages

Ubuntu:14.04:LTS / freetype

Package

Name
freetype

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.5.2-1ubuntu2.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "freetype2-demos": "2.5.2-1ubuntu2.4",
            "libfreetype6": "2.5.2-1ubuntu2.4",
            "libfreetype6-udeb": "2.5.2-1ubuntu2.4",
            "libfreetype6-dev": "2.5.2-1ubuntu2.4"
        }
    ]
}