USN-2559-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-2559-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-2559-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-2559-1
Related
  • CVE-2015-2806
Published
2015-04-08T14:32:10.269494Z
Modified
2015-04-08T14:32:10.269494Z
Summary
libtasn1-3, libtasn1-6 vulnerability
Details

Hanno Böck discovered that Libtasn1 incorrectly handled certain ASN.1 data. A remote attacker could possibly exploit this with specially crafted ASN.1 data and cause applications using Libtasn1 to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:14.04:LTS / libtasn1-6

Package

Name
libtasn1-6

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.4-3ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libtasn1-3-dev": "3.4-3ubuntu0.2",
            "libtasn1-6-dev": "3.4-3ubuntu0.2",
            "libtasn1-bin": "3.4-3ubuntu0.2",
            "libtasn1-6": "3.4-3ubuntu0.2",
            "libtasn1-3-bin": "3.4-3ubuntu0.2"
        }
    ]
}