USN-2790-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-2790-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-2790-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-2790-1
Related
  • CVE-2015-7183
Published
2015-11-04T20:54:30.479452Z
Modified
2015-11-04T20:54:30.479452Z
Summary
nspr vulnerability
Details

Ryan Sleevi discovered that NSPR incorrectly handled memory allocation. A remote attacker could use this issue to cause NSPR to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:14.04:LTS / nspr

Package

Name
nspr

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:4.10.10-0ubuntu0.14.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libnspr4-0d": "2:4.10.10-0ubuntu0.14.04.1",
            "libnspr4-dev": "2:4.10.10-0ubuntu0.14.04.1",
            "libnspr4": "2:4.10.10-0ubuntu0.14.04.1"
        }
    ]
}