USN-2913-3

See a problem?
Source
https://ubuntu.com/security/notices/USN-2913-3
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-2913-3.json
JSON Data
https://api.osv.dev/v1/vulns/USN-2913-3
Published
2016-02-24T17:27:37.351227Z
Modified
2016-02-24T17:27:37.351227Z
Summary
openssl update
Details

USN-2913-1 removed 1024-bit RSA CA certificates from the ca-certificates package. This update adds support for alternate certificate chains to the OpenSSL package to properly handle the removal.

Original advisory details:

The ca-certificates package contained outdated CA certificates. This update refreshes the included certificates to those contained in the 20160104 package, including the removal of the SPI CA and CA certificates with 1024-bit RSA keys.

References

Affected packages

Ubuntu:14.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.1f-1ubuntu2.17

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl-dev": "1.0.1f-1ubuntu2.17",
            "openssl": "1.0.1f-1ubuntu2.17",
            "libssl-doc": "1.0.1f-1ubuntu2.17",
            "libssl1.0.0-udeb": "1.0.1f-1ubuntu2.17",
            "libssl1.0.0": "1.0.1f-1ubuntu2.17",
            "libcrypto1.0.0-udeb": "1.0.1f-1ubuntu2.17"
        }
    ]
}