USN-2990-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-2990-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-2990-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-2990-1
Related
Published
2016-06-02T13:13:20.182108Z
Modified
2016-06-02T13:13:20.182108Z
Summary
imagemagick vulnerabilities
Details

Nikolay Ermishkin and Stewie discovered that ImageMagick incorrectly sanitized untrusted input. A remote attacker could use these issues to execute arbitrary code. These issues are known as "ImageTragick". This update disables problematic coders via the /etc/ImageMagick-6/policy.xml configuration file. In certain environments the coders may need to be manually re-enabled after making sure that ImageMagick does not process untrusted input. (CVE-2016-3714, CVE-2016-3715, CVE-2016-3716, CVE-2016-3717, CVE-2016-3718)

Bob Friesenhahn discovered that ImageMagick allowed injecting commands via an image file or filename. A remote attacker could use this issue to execute arbitrary code. (CVE-2016-5118)

References

Affected packages

Ubuntu:16.04:LTS / imagemagick

Package

Name
imagemagick

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8:6.8.9.9-7ubuntu5.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libmagickcore-6.q16-2": "8:6.8.9.9-7ubuntu5.1",
            "imagemagick-common": "8:6.8.9.9-7ubuntu5.1",
            "libimage-magick-q16-perl": "8:6.8.9.9-7ubuntu5.1",
            "imagemagick-doc": "8:6.8.9.9-7ubuntu5.1",
            "libmagick++-6.q16-5v5": "8:6.8.9.9-7ubuntu5.1",
            "libmagick++-dev": "8:6.8.9.9-7ubuntu5.1",
            "libmagickwand-6.q16-2": "8:6.8.9.9-7ubuntu5.1",
            "libimage-magick-perl": "8:6.8.9.9-7ubuntu5.1",
            "imagemagick": "8:6.8.9.9-7ubuntu5.1",
            "libmagickwand-6.q16-dev": "8:6.8.9.9-7ubuntu5.1",
            "libmagickcore-6-arch-config": "8:6.8.9.9-7ubuntu5.1",
            "imagemagick-6.q16": "8:6.8.9.9-7ubuntu5.1",
            "libmagickcore-6.q16-2-extra": "8:6.8.9.9-7ubuntu5.1",
            "libmagickcore-6.q16-dev": "8:6.8.9.9-7ubuntu5.1",
            "libmagickwand-dev": "8:6.8.9.9-7ubuntu5.1",
            "libmagick++-6.q16-dev": "8:6.8.9.9-7ubuntu5.1",
            "perlmagick": "8:6.8.9.9-7ubuntu5.1",
            "libmagickwand-6-headers": "8:6.8.9.9-7ubuntu5.1",
            "libmagickcore-6-headers": "8:6.8.9.9-7ubuntu5.1",
            "libmagick++-6-headers": "8:6.8.9.9-7ubuntu5.1",
            "libmagickcore-dev": "8:6.8.9.9-7ubuntu5.1"
        }
    ]
}

Ubuntu:14.04:LTS / imagemagick

Package

Name
imagemagick

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8:6.7.7.10-6ubuntu3.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libmagickcore5-extra": "8:6.7.7.10-6ubuntu3.1",
            "libmagickcore5": "8:6.7.7.10-6ubuntu3.1",
            "libmagickcore-dev": "8:6.7.7.10-6ubuntu3.1",
            "imagemagick-doc": "8:6.7.7.10-6ubuntu3.1",
            "libmagick++5": "8:6.7.7.10-6ubuntu3.1",
            "libmagick++-dev": "8:6.7.7.10-6ubuntu3.1",
            "perlmagick": "8:6.7.7.10-6ubuntu3.1",
            "imagemagick": "8:6.7.7.10-6ubuntu3.1",
            "libmagickwand5": "8:6.7.7.10-6ubuntu3.1",
            "libmagickwand-dev": "8:6.7.7.10-6ubuntu3.1",
            "imagemagick-common": "8:6.7.7.10-6ubuntu3.1"
        }
    ]
}