USN-3068-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3068-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3068-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3068-1
Related
Published
2016-08-24T13:30:51.011300Z
Modified
2016-08-24T13:30:51.011300Z
Summary
libidn vulnerabilities
Details

Thijs Alkemade, Gustavo Grieco, Daniel Stenberg, and Nikos Mavrogiannopoulos discovered that Libidn incorrectly handled invalid UTF-8 characters. A remote attacker could use this issue to cause Libidn to crash, resulting in a denial of service, or possibly disclose sensitive memory. This issue only applied to Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2015-2059)

Hanno Böck discovered that Libidn incorrectly handled certain input. A remote attacker could possibly use this issue to cause Libidn to crash, resulting in a denial of service. (CVE-2015-8948, CVE-2016-6262, CVE-2016-6261, CVE-2016-6263)

References

Affected packages

Ubuntu:14.04:LTS / libidn

Package

Name
libidn

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.28-1ubuntu2.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libidn11-java": "1.28-1ubuntu2.1",
            "idn": "1.28-1ubuntu2.1",
            "libidn11-dev": "1.28-1ubuntu2.1",
            "libidn11": "1.28-1ubuntu2.1"
        }
    ]
}

Ubuntu:16.04:LTS / libidn

Package

Name
libidn

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.32-3ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libidn11-java": "1.32-3ubuntu1.1",
            "idn": "1.32-3ubuntu1.1",
            "libidn11-dev": "1.32-3ubuntu1.1",
            "libidn11": "1.32-3ubuntu1.1"
        }
    ]
}