USN-3142-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-3142-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3142-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3142-2
Published
2017-02-22T19:59:54.053293Z
Modified
2017-02-22T19:59:54.053293Z
Summary
imagemagick regression
Details

USN-3142-1 fixed vulnerabilities in ImageMagick. The security fixes introduced a regression with text labels and a regression with the text coder. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

It was discovered that ImageMagick incorrectly handled certain malformed image files. If a user or automated system using ImageMagick were tricked into opening a specially crafted image, an attacker could exploit this to cause a denial of service or possibly execute code with the privileges of the user invoking the program.

References

Affected packages

Ubuntu:14.04:LTS / imagemagick

Package

Name
imagemagick

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8:6.7.7.10-6ubuntu3.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libmagickcore5-extra": "8:6.7.7.10-6ubuntu3.4",
            "libmagickcore5": "8:6.7.7.10-6ubuntu3.4",
            "libmagickcore-dev": "8:6.7.7.10-6ubuntu3.4",
            "imagemagick-doc": "8:6.7.7.10-6ubuntu3.4",
            "libmagick++5": "8:6.7.7.10-6ubuntu3.4",
            "libmagick++-dev": "8:6.7.7.10-6ubuntu3.4",
            "perlmagick": "8:6.7.7.10-6ubuntu3.4",
            "imagemagick": "8:6.7.7.10-6ubuntu3.4",
            "libmagickwand5": "8:6.7.7.10-6ubuntu3.4",
            "libmagickwand-dev": "8:6.7.7.10-6ubuntu3.4",
            "imagemagick-common": "8:6.7.7.10-6ubuntu3.4"
        }
    ]
}

Ubuntu:16.04:LTS / imagemagick

Package

Name
imagemagick

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8:6.8.9.9-7ubuntu5.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libmagickcore-6.q16-2": "8:6.8.9.9-7ubuntu5.4",
            "imagemagick-common": "8:6.8.9.9-7ubuntu5.4",
            "libimage-magick-q16-perl": "8:6.8.9.9-7ubuntu5.4",
            "imagemagick-doc": "8:6.8.9.9-7ubuntu5.4",
            "libmagick++-6.q16-5v5": "8:6.8.9.9-7ubuntu5.4",
            "libmagick++-dev": "8:6.8.9.9-7ubuntu5.4",
            "libmagickwand-6.q16-2": "8:6.8.9.9-7ubuntu5.4",
            "libimage-magick-perl": "8:6.8.9.9-7ubuntu5.4",
            "imagemagick": "8:6.8.9.9-7ubuntu5.4",
            "libmagickwand-6.q16-dev": "8:6.8.9.9-7ubuntu5.4",
            "libmagickcore-6-arch-config": "8:6.8.9.9-7ubuntu5.4",
            "imagemagick-6.q16": "8:6.8.9.9-7ubuntu5.4",
            "libmagickcore-6.q16-2-extra": "8:6.8.9.9-7ubuntu5.4",
            "libmagickcore-6.q16-dev": "8:6.8.9.9-7ubuntu5.4",
            "libmagickwand-dev": "8:6.8.9.9-7ubuntu5.4",
            "libmagick++-6.q16-dev": "8:6.8.9.9-7ubuntu5.4",
            "perlmagick": "8:6.8.9.9-7ubuntu5.4",
            "libmagickwand-6-headers": "8:6.8.9.9-7ubuntu5.4",
            "libmagickcore-6-headers": "8:6.8.9.9-7ubuntu5.4",
            "libmagick++-6-headers": "8:6.8.9.9-7ubuntu5.4",
            "libmagickcore-dev": "8:6.8.9.9-7ubuntu5.4"
        }
    ]
}