USN-3169-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3169-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3169-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3169-1
Related
  • CVE-2016-9756
  • CVE-2016-9793
  • CVE-2016-9794
Published
2017-01-11T07:07:11.138323Z
Modified
2017-01-11T07:07:11.138323Z
Summary
linux vulnerabilities
Details

Dmitry Vyukov discovered that the KVM implementation in the Linux kernel did not properly initialize the Code Segment (CS) in certain error cases. A local attacker could use this to expose sensitive information (kernel memory). (CVE-2016-9756)

Andrey Konovalov discovered that signed integer overflows existed in the setsockopt() system call when handling the SOSNDBUFFORCE and SORCVBUFFORCE options. A local attacker with the CAPNETADMIN capability could use this to cause a denial of service (system crash or memory corruption). (CVE-2016-9793)

Baozeng Ding discovered a race condition that could lead to a use-after- free in the Advanced Linux Sound Architecture (ALSA) subsystem of the Linux kernel. A local attacker could use this to cause a denial of service (system crash). (CVE-2016-9794)

References

Affected packages

Ubuntu:16.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-59.80

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.4.0-59-powerpc-e500mc": "4.4.0-59.80",
            "linux-image-4.4.0-59-powerpc64-smp": "4.4.0-59.80",
            "linux-image-4.4.0-59-generic": "4.4.0-59.80",
            "linux-image-extra-4.4.0-59-generic": "4.4.0-59.80",
            "linux-image-4.4.0-59-generic-lpae": "4.4.0-59.80",
            "linux-image-4.4.0-59-lowlatency": "4.4.0-59.80",
            "linux-image-4.4.0-59-powerpc-smp": "4.4.0-59.80",
            "linux-image-4.4.0-59-powerpc64-emb": "4.4.0-59.80"
        }
    ]
}