USN-3176-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3176-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3176-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3176-1
Related
  • CVE-2016-10109
Published
2017-01-23T17:59:44.877109Z
Modified
2017-01-23T17:59:44.877109Z
Summary
pcsc-lite vulnerability
Details

Peter Wu discovered that the PC/SC service did not correctly handle certain resources. A local attacker could use this issue to cause PC/SC to crash, resulting in a denial of service, or possibly execute arbitrary code with root privileges.

References

Affected packages

Ubuntu:14.04:LTS / pcsc-lite

Package

Name
pcsc-lite

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.8.10-1ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "pcscd": "1.8.10-1ubuntu1.1",
            "libpcsclite1": "1.8.10-1ubuntu1.1",
            "libpcsclite-dev": "1.8.10-1ubuntu1.1"
        }
    ]
}

Ubuntu:16.04:LTS / pcsc-lite

Package

Name
pcsc-lite

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.8.14-1ubuntu1.16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "pcscd": "1.8.14-1ubuntu1.16.04.1",
            "libpcsclite1": "1.8.14-1ubuntu1.16.04.1",
            "libpcsclite-dev": "1.8.14-1ubuntu1.16.04.1"
        }
    ]
}