USN-3197-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3197-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3197-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3197-1
Related
Published
2017-02-15T18:00:58.086492Z
Modified
2017-02-15T18:00:58.086492Z
Summary
libgc vulnerability
Details

Kuang-che Wu discovered that multiple integer overflow vulnerabilities existed in libgc. An attacker could use these to cause a denial of service (application crash) or possibly execute arbitrary code.

References

Affected packages

Ubuntu:14.04:LTS / libgc

Package

Name
libgc

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:7.2d-5ubuntu2.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgc1c2": "1:7.2d-5ubuntu2.1",
            "libgc-dev": "1:7.2d-5ubuntu2.1"
        }
    ]
}

Ubuntu:16.04:LTS / libgc

Package

Name
libgc

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:7.4.2-7.3ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgc1c2": "1:7.4.2-7.3ubuntu0.1",
            "libgc-dev": "1:7.4.2-7.3ubuntu0.1"
        }
    ]
}