USN-3203-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3203-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3203-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3203-1
Related
Published
2017-02-20T17:59:30.703592Z
Modified
2017-02-20T17:59:30.703592Z
Summary
gtk-vnc vulnerabilities
Details

It was discovered that gtk-vnc incorrectly validated certain data. A malicious server could use this issue to cause gtk-vnc to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:14.04:LTS / gtk-vnc

Package

Name
gtk-vnc

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.5.3-0ubuntu2.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgvnc-1.0-0": "0.5.3-0ubuntu2.1",
            "libgtk-vnc-2.0-dev": "0.5.3-0ubuntu2.1",
            "gir1.2-gtk-vnc-2.0": "0.5.3-0ubuntu2.1",
            "libgtk-vnc-1.0-0": "0.5.3-0ubuntu2.1",
            "python-gtk-vnc": "0.5.3-0ubuntu2.1",
            "gvncviewer": "0.5.3-0ubuntu2.1",
            "libgtk-vnc-2.0-0": "0.5.3-0ubuntu2.1",
            "libgvnc-1.0-dev": "0.5.3-0ubuntu2.1",
            "libgtk-vnc-1.0-dev": "0.5.3-0ubuntu2.1"
        }
    ]
}