USN-3212-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-3212-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3212-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3212-2
Published
2017-05-30T14:04:34.619630Z
Modified
2017-05-30T14:04:34.619630Z
Summary
tiff regression
Details

USN-3212-1 fixed vulnerabilities in LibTIFF. Unfortunately, some of the security patches were misapplied, which caused a regression when processing certain images. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

It was discovered that LibTIFF incorrectly handled certain malformed images. If a user or automated system were tricked into opening a specially crafted image, a remote attacker could crash the application, leading to a denial of service, or possibly execute arbitrary code with user privileges.

References

Affected packages

Ubuntu:14.04:LTS / tiff

Package

Name
tiff

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.0.3-7ubuntu0.7

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libtiff-doc": "4.0.3-7ubuntu0.7",
            "libtiff-opengl": "4.0.3-7ubuntu0.7",
            "libtiff4-dev": "4.0.3-7ubuntu0.7",
            "libtiff5-alt-dev": "4.0.3-7ubuntu0.7",
            "libtiff5": "4.0.3-7ubuntu0.7",
            "libtiff-tools": "4.0.3-7ubuntu0.7",
            "libtiffxx5": "4.0.3-7ubuntu0.7",
            "libtiff5-dev": "4.0.3-7ubuntu0.7"
        }
    ]
}

Ubuntu:16.04:LTS / tiff

Package

Name
tiff

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.0.6-1ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libtiff5": "4.0.6-1ubuntu0.2",
            "libtiff-doc": "4.0.6-1ubuntu0.2",
            "libtiff-opengl": "4.0.6-1ubuntu0.2",
            "libtiff-tools": "4.0.6-1ubuntu0.2",
            "libtiffxx5": "4.0.6-1ubuntu0.2",
            "libtiff5-dev": "4.0.6-1ubuntu0.2"
        }
    ]
}