USN-3224-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3224-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3224-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3224-1
Related
Published
2017-03-09T16:28:44.167370Z
Modified
2017-03-09T16:28:44.167370Z
Summary
lxc vulnerability
Details

Jann Horn discovered that LXC incorrectly verified permissions when creating virtual network interfaces. A local attacker could possibly use this issue to create virtual network interfaces in network namespaces that they do not own.

References

Affected packages

Ubuntu:14.04:LTS / lxc

Package

Name
lxc

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.9-0ubuntu3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "lxc": "1.0.9-0ubuntu3",
            "python3-lxc": "1.0.9-0ubuntu3",
            "lxc-dev": "1.0.9-0ubuntu3",
            "liblxc1": "1.0.9-0ubuntu3",
            "lxc-templates": "1.0.9-0ubuntu3",
            "lxc-tests": "1.0.9-0ubuntu3"
        }
    ]
}

Ubuntu:16.04:LTS / lxc

Package

Name
lxc

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.0.7-0ubuntu1~16.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "lxc-common": "2.0.7-0ubuntu1~16.04.2",
            "python3-lxc": "2.0.7-0ubuntu1~16.04.2",
            "lxc-dev": "2.0.7-0ubuntu1~16.04.2",
            "liblxc1": "2.0.7-0ubuntu1~16.04.2",
            "lua-lxc": "2.0.7-0ubuntu1~16.04.2",
            "lxc-tests": "2.0.7-0ubuntu1~16.04.2",
            "lxc-templates": "2.0.7-0ubuntu1~16.04.2",
            "lxc1": "2.0.7-0ubuntu1~16.04.2",
            "lxc": "2.0.7-0ubuntu1~16.04.2"
        }
    ]
}