USN-3237-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3237-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3237-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3237-1
Related
Published
2017-03-20T16:32:46.929244Z
Modified
2017-03-20T16:32:46.929244Z
Summary
freetype vulnerability
Details

It was discovered that FreeType did not correctly handle certain malformed font files. If a user were tricked into using a specially crafted font file, a remote attacker could cause FreeType to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:14.04:LTS / freetype

Package

Name
freetype

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.5.2-1ubuntu2.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "freetype2-demos": "2.5.2-1ubuntu2.6",
            "libfreetype6": "2.5.2-1ubuntu2.6",
            "libfreetype6-udeb": "2.5.2-1ubuntu2.6",
            "libfreetype6-dev": "2.5.2-1ubuntu2.6"
        }
    ]
}

Ubuntu:16.04:LTS / freetype

Package

Name
freetype

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6.1-0.1ubuntu2.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "freetype2-demos": "2.6.1-0.1ubuntu2.1",
            "libfreetype6": "2.6.1-0.1ubuntu2.1",
            "libfreetype6-udeb": "2.6.1-0.1ubuntu2.1",
            "libfreetype6-dev": "2.6.1-0.1ubuntu2.1"
        }
    ]
}