USN-3254-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3254-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3254-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3254-1
Related
Published
2017-04-04T17:09:19.018696Z
Modified
2017-04-04T17:09:19.018696Z
Summary
python-django vulnerabilities
Details

It was discovered that Django incorrectly handled numeric redirect URLs. A remote attacker could possibly use this issue to perform XSS attacks, and to use a Django server as an open redirect. (CVE-2017-7233)

Phithon Gong discovered that Django incorrectly handled certain URLs when the jango.views.static.serve() view is being used. A remote attacker could possibly use a Django server as an open redirect. (CVE-2017-7234)

References

Affected packages

Ubuntu:14.04:LTS / python-django

Package

Name
python-django

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6.11-0ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-django-doc": "1.6.11-0ubuntu1.1",
            "python-django": "1.6.11-0ubuntu1.1"
        }
    ]
}

Ubuntu:16.04:LTS / python-django

Package

Name
python-django

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.8.7-1ubuntu5.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-django-common": "1.8.7-1ubuntu5.5",
            "python-django-doc": "1.8.7-1ubuntu5.5",
            "python-django": "1.8.7-1ubuntu5.5",
            "python3-django": "1.8.7-1ubuntu5.5"
        }
    ]
}