USN-3256-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-3256-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3256-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3256-2
Related
  • CVE-2017-7308
Published
2017-04-05T04:08:27.804347Z
Modified
2017-04-05T04:08:27.804347Z
Summary
linux-hwe, linux-lts-trusty, linux-lts-xenial vulnerability
Details

USN-3256-1 fixed vulnerabilities in the Linux kernel for Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, and Ubuntu 16.10. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel for each of the respective prior Ubuntu LTS releases.

Andrey Konovalov discovered that the AF_PACKET implementation in the Linux kernel did not properly validate certain block-size data. A local attacker could use this to cause a denial of service (system crash).

References

Affected packages

Ubuntu:14.04:LTS / linux-lts-xenial

Package

Name
linux-lts-xenial

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-72.93~14.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-extra-4.4.0-72-generic": "4.4.0-72.93~14.04.1",
            "linux-image-4.4.0-72-powerpc64-emb": "4.4.0-72.93~14.04.1",
            "linux-image-4.4.0-72-lowlatency": "4.4.0-72.93~14.04.1",
            "linux-image-4.4.0-72-powerpc64-smp": "4.4.0-72.93~14.04.1",
            "linux-image-4.4.0-72-powerpc-smp": "4.4.0-72.93~14.04.1",
            "linux-image-4.4.0-72-powerpc-e500mc": "4.4.0-72.93~14.04.1",
            "linux-image-4.4.0-72-generic": "4.4.0-72.93~14.04.1",
            "linux-image-4.4.0-72-generic-lpae": "4.4.0-72.93~14.04.1"
        }
    ]
}

Ubuntu:16.04:LTS / linux-hwe

Package

Name
linux-hwe

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.8.0-46.49~16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.8.0-46-generic-lpae": "4.8.0-46.49~16.04.1",
            "linux-image-4.8.0-46-lowlatency": "4.8.0-46.49~16.04.1",
            "linux-image-4.8.0-46-generic": "4.8.0-46.49~16.04.1",
            "linux-image-extra-4.8.0-46-generic": "4.8.0-46.49~16.04.1"
        }
    ]
}