USN-3258-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-3258-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3258-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3258-2
Related
Published
2017-04-11T19:41:41.507731Z
Modified
2017-04-11T19:41:41.507731Z
Summary
dovecot regression
Details

USN-3258-1 intended to fix a vulnerability in Dovecot. Further investigation revealed that only Dovecot versions 2.2.26 and newer were affected by the vulnerability. Additionally, the change introduced a regression when Dovecot was configured to use the "dict" authentication database. This update reverts the change. We apologize for the inconvenience.

Original advisory details:

It was discovered that Dovecot incorrectly handled some usernames. An attacker could possibly use this issue to cause Dovecot to hang or crash, resulting in a denial of service.

References

Affected packages

Ubuntu:16.04:LTS / dovecot

Package

Name
dovecot

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2.2.22-1ubuntu2.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "dovecot-solr": "1:2.2.22-1ubuntu2.4",
            "dovecot-ldap": "1:2.2.22-1ubuntu2.4",
            "dovecot-managesieved": "1:2.2.22-1ubuntu2.4",
            "dovecot-pop3d": "1:2.2.22-1ubuntu2.4",
            "dovecot-sieve": "1:2.2.22-1ubuntu2.4",
            "mail-stack-delivery": "1:2.2.22-1ubuntu2.4",
            "dovecot-imapd": "1:2.2.22-1ubuntu2.4",
            "dovecot-core": "1:2.2.22-1ubuntu2.4",
            "dovecot-lmtpd": "1:2.2.22-1ubuntu2.4",
            "dovecot-pgsql": "1:2.2.22-1ubuntu2.4",
            "dovecot-mysql": "1:2.2.22-1ubuntu2.4",
            "dovecot-lucene": "1:2.2.22-1ubuntu2.4",
            "dovecot-gssapi": "1:2.2.22-1ubuntu2.4",
            "dovecot-sqlite": "1:2.2.22-1ubuntu2.4",
            "dovecot-dev": "1:2.2.22-1ubuntu2.4"
        }
    ]
}