USN-3272-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-3272-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3272-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3272-2
Published
2017-05-16T18:58:49.644801Z
Modified
2017-05-16T18:58:49.644801Z
Summary
ghostscript regression
Details

USN-3272-1 fixed vulnerabilities in Ghostscript. This change introduced a regression when the DELAYBIND feature is used with the eqproc command. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

It was discovered that Ghostscript improperly handled parameters to the rsdparams and eqproc commands. An attacker could use these to craft a malicious document that could disable -dSAFER protections, thereby allowing the execution of arbitrary code, or cause a denial of service (application crash). (CVE-2017-8291)

Kamil Frankowicz discovered a use-after-free vulnerability in the color management module of Ghostscript. An attacker could use this to cause a denial of service (application crash). (CVE-2016-10217)

Kamil Frankowicz discovered a divide-by-zero error in the scan conversion code in Ghostscript. An attacker could use this to cause a denial of service (application crash). (CVE-2016-10219)

Kamil Frankowicz discovered multiple NULL pointer dereference errors in Ghostscript. An attacker could use these to cause a denial of service (application crash). (CVE-2016-10220, CVE-2017-5951, CVE-2017-7207)

References

Affected packages

Ubuntu:14.04:LTS / ghostscript

Package

Name
ghostscript

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
9.10~dfsg-0ubuntu10.9

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgs-dev": "9.10~dfsg-0ubuntu10.9",
            "libgs9-common": "9.10~dfsg-0ubuntu10.9",
            "ghostscript": "9.10~dfsg-0ubuntu10.9",
            "ghostscript-doc": "9.10~dfsg-0ubuntu10.9",
            "ghostscript-x": "9.10~dfsg-0ubuntu10.9",
            "libgs9": "9.10~dfsg-0ubuntu10.9"
        }
    ]
}

Ubuntu:16.04:LTS / ghostscript

Package

Name
ghostscript

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
9.18~dfsg~0-0ubuntu2.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgs-dev": "9.18~dfsg~0-0ubuntu2.6",
            "libgs9-common": "9.18~dfsg~0-0ubuntu2.6",
            "ghostscript": "9.18~dfsg~0-0ubuntu2.6",
            "ghostscript-doc": "9.18~dfsg~0-0ubuntu2.6",
            "ghostscript-x": "9.18~dfsg~0-0ubuntu2.6",
            "libgs9": "9.18~dfsg~0-0ubuntu2.6"
        }
    ]
}