USN-3334-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3334-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3334-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3334-1
Related
  • CVE-2017-1000364
Published
2017-06-22T05:19:26.341924Z
Modified
2017-06-22T05:19:26.341924Z
Summary
linux-lts-xenial vulnerability
Details

USN-3328-1 fixed vulnerabilities in the Linux kernel for Ubuntu 16.04 LTS. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 16.04 LTS for Ubuntu 14.04 LTS.

It was discovered that the stack guard page for processes in the Linux kernel was not sufficiently large enough to prevent overlapping with the heap. An attacker could leverage this with another vulnerability to execute arbitrary code and gain administrative privileges

References

Affected packages

Ubuntu:14.04:LTS / linux-lts-xenial

Package

Name
linux-lts-xenial

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-81.104~14.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.4.0-81-powerpc-e500mc": "4.4.0-81.104~14.04.1",
            "linux-image-4.4.0-81-powerpc-smp": "4.4.0-81.104~14.04.1",
            "linux-image-4.4.0-81-generic": "4.4.0-81.104~14.04.1",
            "linux-image-4.4.0-81-lowlatency": "4.4.0-81.104~14.04.1",
            "linux-image-4.4.0-81-powerpc64-smp": "4.4.0-81.104~14.04.1",
            "linux-image-extra-4.4.0-81-generic": "4.4.0-81.104~14.04.1",
            "linux-image-4.4.0-81-generic-lpae": "4.4.0-81.104~14.04.1",
            "linux-image-4.4.0-81-powerpc64-emb": "4.4.0-81.104~14.04.1"
        }
    ]
}