USN-3352-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3352-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3352-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3352-1
Related
Published
2017-07-13T18:38:55.835635Z
Modified
2017-07-13T18:38:55.835635Z
Summary
nginx vulnerability
Details

It was discovered that an integer overflow existed in the range filter feature of nginx. A remote attacker could use this to expose sensitive information.

References

Affected packages

Ubuntu:14.04:LTS / nginx

Package

Name
nginx

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.4.6-1ubuntu3.8

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "nginx-light": "1.4.6-1ubuntu3.8",
            "nginx-extras": "1.4.6-1ubuntu3.8",
            "nginx-full": "1.4.6-1ubuntu3.8",
            "nginx-naxsi": "1.4.6-1ubuntu3.8",
            "nginx": "1.4.6-1ubuntu3.8",
            "nginx-common": "1.4.6-1ubuntu3.8",
            "nginx-naxsi-ui": "1.4.6-1ubuntu3.8",
            "nginx-core": "1.4.6-1ubuntu3.8",
            "nginx-doc": "1.4.6-1ubuntu3.8"
        }
    ]
}

Ubuntu:16.04:LTS / nginx

Package

Name
nginx

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.10.3-0ubuntu0.16.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "nginx-light": "1.10.3-0ubuntu0.16.04.2",
            "nginx-extras": "1.10.3-0ubuntu0.16.04.2",
            "nginx-common": "1.10.3-0ubuntu0.16.04.2",
            "nginx-full": "1.10.3-0ubuntu0.16.04.2",
            "nginx": "1.10.3-0ubuntu0.16.04.2",
            "nginx-core": "1.10.3-0ubuntu0.16.04.2",
            "nginx-doc": "1.10.3-0ubuntu0.16.04.2"
        }
    ]
}