USN-3383-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3383-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3383-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3383-1
Related
Published
2017-08-10T17:06:05.907482Z
Modified
2017-08-10T17:06:05.907482Z
Summary
libsoup2.4 vulnerability
Details

Aleksandar Nikolic discovered a stack based buffer overflow when handling chunked encoding. An attacker could use this to cause a denial of service or possibly execute arbitrary code.

References

Affected packages

Ubuntu:14.04:LTS / libsoup2.4

Package

Name
libsoup2.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.44.2-1ubuntu2.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "gir1.2-soup-2.4": "2.44.2-1ubuntu2.2",
            "libsoup-gnome2.4-1": "2.44.2-1ubuntu2.2",
            "libsoup-gnome2.4-dev": "2.44.2-1ubuntu2.2",
            "libsoup2.4-doc": "2.44.2-1ubuntu2.2",
            "libsoup2.4-dev": "2.44.2-1ubuntu2.2",
            "libsoup2.4-1": "2.44.2-1ubuntu2.2"
        }
    ]
}

Ubuntu:16.04:LTS / libsoup2.4

Package

Name
libsoup2.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.52.2-1ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "gir1.2-soup-2.4": "2.52.2-1ubuntu0.2",
            "libsoup-gnome2.4-1": "2.52.2-1ubuntu0.2",
            "libsoup-gnome2.4-dev": "2.52.2-1ubuntu0.2",
            "libsoup2.4-doc": "2.52.2-1ubuntu0.2",
            "libsoup2.4-dev": "2.52.2-1ubuntu0.2",
            "libsoup2.4-1": "2.52.2-1ubuntu0.2"
        }
    ]
}