USN-3390-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3390-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3390-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3390-1
Related
Published
2017-08-15T16:56:34.219821Z
Modified
2017-08-15T16:56:34.219821Z
Summary
postgresql-9.3, postgresql-9.5, postgresql-9.6 vulnerabilities
Details

Ben de Graaff, Jelte Fennema, and Jeroen van der Ham discovered that PostgreSQL allowed the use of empty passwords in some authentication methods, contrary to expected behaviour. A remote attacker could use an empty password to authenticate to servers that were believed to have password login disabled. (CVE-2017-7546)

Jeff Janes discovered that PostgreSQL incorrectly handled the pgusermappings catalog view. A remote attacker without server privileges could possibly use this issue to obtain certain passwords. (CVE-2017-7547)

Chapman Flack discovered that PostgreSQL incorrectly handled lo_put() permissions. A remote attacker could possibly use this issue to change the data in a large object. (CVE-2017-7548)

References

Affected packages

Ubuntu:14.04:LTS / postgresql-9.3

Package

Name
postgresql-9.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
9.3.18-0ubuntu0.14.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libecpg6": "9.3.18-0ubuntu0.14.04.1",
            "postgresql-9.3": "9.3.18-0ubuntu0.14.04.1",
            "libecpg-dev": "9.3.18-0ubuntu0.14.04.1",
            "libpq5": "9.3.18-0ubuntu0.14.04.1",
            "postgresql-plpython3-9.3": "9.3.18-0ubuntu0.14.04.1",
            "postgresql-doc-9.3": "9.3.18-0ubuntu0.14.04.1",
            "libpgtypes3": "9.3.18-0ubuntu0.14.04.1",
            "postgresql-contrib-9.3": "9.3.18-0ubuntu0.14.04.1",
            "libpq-dev": "9.3.18-0ubuntu0.14.04.1",
            "postgresql-plpython-9.3": "9.3.18-0ubuntu0.14.04.1",
            "postgresql-plperl-9.3": "9.3.18-0ubuntu0.14.04.1",
            "postgresql-server-dev-9.3": "9.3.18-0ubuntu0.14.04.1",
            "libecpg-compat3": "9.3.18-0ubuntu0.14.04.1",
            "postgresql-pltcl-9.3": "9.3.18-0ubuntu0.14.04.1",
            "postgresql-client-9.3": "9.3.18-0ubuntu0.14.04.1"
        }
    ]
}

Ubuntu:16.04:LTS / postgresql-9.5

Package

Name
postgresql-9.5

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
9.5.8-0ubuntu0.16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libecpg6": "9.5.8-0ubuntu0.16.04.1",
            "postgresql-doc-9.5": "9.5.8-0ubuntu0.16.04.1",
            "postgresql-server-dev-9.5": "9.5.8-0ubuntu0.16.04.1",
            "libecpg-dev": "9.5.8-0ubuntu0.16.04.1",
            "libpq5": "9.5.8-0ubuntu0.16.04.1",
            "postgresql-9.5": "9.5.8-0ubuntu0.16.04.1",
            "postgresql-plpython3-9.5": "9.5.8-0ubuntu0.16.04.1",
            "libpq-dev": "9.5.8-0ubuntu0.16.04.1",
            "postgresql-plperl-9.5": "9.5.8-0ubuntu0.16.04.1",
            "libpgtypes3": "9.5.8-0ubuntu0.16.04.1",
            "postgresql-pltcl-9.5": "9.5.8-0ubuntu0.16.04.1",
            "postgresql-plpython-9.5": "9.5.8-0ubuntu0.16.04.1",
            "libecpg-compat3": "9.5.8-0ubuntu0.16.04.1",
            "postgresql-client-9.5": "9.5.8-0ubuntu0.16.04.1",
            "postgresql-contrib-9.5": "9.5.8-0ubuntu0.16.04.1"
        }
    ]
}