USN-3395-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3395-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3395-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3395-1
Related
Published
2017-08-17T17:09:39.424476Z
Modified
2017-08-17T17:09:39.424476Z
Summary
c-ares vulnerability
Details

It was discovered that c-ares incorrectly handled certain NAPTR responses. A remote attacker could possibly use this issue to cause applications using c-ares to crash, resulting in a denial of service.

References

Affected packages

Ubuntu:14.04:LTS / c-ares

Package

Name
c-ares

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.10.0-2ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libc-ares-dev": "1.10.0-2ubuntu0.2",
            "libc-ares2": "1.10.0-2ubuntu0.2"
        }
    ]
}

Ubuntu:16.04:LTS / c-ares

Package

Name
c-ares

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.10.0-3ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libc-ares-dev": "1.10.0-3ubuntu0.2",
            "libc-ares2": "1.10.0-3ubuntu0.2"
        }
    ]
}