USN-3424-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3424-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3424-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3424-1
Related
Published
2017-09-19T00:47:53.028766Z
Modified
2017-09-19T00:47:53.028766Z
Summary
libxml2 vulnerabilities
Details

It was discovered that a type confusion error existed in libxml2. An attacker could use this to specially construct XML data that could cause a denial of service or possibly execute arbitrary code. (CVE-2017-0663)

It was discovered that libxml2 did not properly validate parsed entity references. An attacker could use this to specially construct XML data that could expose sensitive information. (CVE-2017-7375)

It was discovered that a buffer overflow existed in libxml2 when handling HTTP redirects. An attacker could use this to specially construct XML data that could cause a denial of service or possibly execute arbitrary code. (CVE-2017-7376)

Marcel Böhme and Van-Thuan Pham discovered a buffer overflow in libxml2 when handling elements. An attacker could use this to specially construct XML data that could cause a denial of service or possibly execute arbitrary code. (CVE-2017-9047)

Marcel Böhme and Van-Thuan Pham discovered a buffer overread in libxml2 when handling elements. An attacker could use this to specially construct XML data that could cause a denial of service. (CVE-2017-9048)

Marcel Böhme and Van-Thuan Pham discovered multiple buffer overreads in libxml2 when handling parameter-entity references. An attacker could use these to specially construct XML data that could cause a denial of service. (CVE-2017-9049, CVE-2017-9050)

References

Affected packages

Ubuntu:14.04:LTS / libxml2

Package

Name
libxml2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9.1+dfsg1-3ubuntu4.10

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libxml2": "2.9.1+dfsg1-3ubuntu4.10",
            "libxml2-doc": "2.9.1+dfsg1-3ubuntu4.10",
            "libxml2-udeb": "2.9.1+dfsg1-3ubuntu4.10",
            "libxml2-dev": "2.9.1+dfsg1-3ubuntu4.10",
            "libxml2-utils": "2.9.1+dfsg1-3ubuntu4.10",
            "python-libxml2": "2.9.1+dfsg1-3ubuntu4.10"
        }
    ]
}

Ubuntu:16.04:LTS / libxml2

Package

Name
libxml2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9.3+dfsg1-1ubuntu0.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libxml2": "2.9.3+dfsg1-1ubuntu0.3",
            "libxml2-doc": "2.9.3+dfsg1-1ubuntu0.3",
            "libxml2-udeb": "2.9.3+dfsg1-1ubuntu0.3",
            "libxml2-dev": "2.9.3+dfsg1-1ubuntu0.3",
            "libxml2-utils": "2.9.3+dfsg1-1ubuntu0.3",
            "python-libxml2": "2.9.3+dfsg1-1ubuntu0.3"
        }
    ]
}