USN-3431-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3431-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3431-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3431-1
Related
  • CVE-2017-7805
Published
2017-10-02T14:04:14.008385Z
Modified
2017-10-02T14:04:14.008385Z
Summary
nss vulnerability
Details

Martin Thomson discovered that NSS incorrectly generated handshake hashes. A remote attacker could use this issue to cause NSS to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:14.04:LTS / nss

Package

Name
nss

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:3.28.4-0ubuntu0.14.04.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libnss3-1d": "2:3.28.4-0ubuntu0.14.04.3",
            "libnss3-tools": "2:3.28.4-0ubuntu0.14.04.3",
            "libnss3": "2:3.28.4-0ubuntu0.14.04.3",
            "libnss3-dev": "2:3.28.4-0ubuntu0.14.04.3",
            "libnss3-nssdb": "2:3.28.4-0ubuntu0.14.04.3"
        }
    ]
}

Ubuntu:16.04:LTS / nss

Package

Name
nss

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:3.28.4-0ubuntu0.16.04.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libnss3-1d": "2:3.28.4-0ubuntu0.16.04.3",
            "libnss3-tools": "2:3.28.4-0ubuntu0.16.04.3",
            "libnss3": "2:3.28.4-0ubuntu0.16.04.3",
            "libnss3-dev": "2:3.28.4-0ubuntu0.16.04.3",
            "libnss3-nssdb": "2:3.28.4-0ubuntu0.16.04.3"
        }
    ]
}