USN-3433-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3433-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3433-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3433-1
Related
Published
2017-10-02T14:35:50.172781Z
Modified
2017-10-02T14:35:50.172781Z
Summary
poppler vulnerabilities
Details

It was discovered that Poppler incorrectly handled certain files. If a user or automated system were tricked into opening a crafted PDF file, an attacker could cause a denial service. This issue only affected Ubuntu 17.04. (CVE-2017-14517)

It was discovered that Poppler incorrectly handled certain files. If a user or automated system were tricked into opening a crafted PDF file, an attacker could cause a denial of service. (CVE-2017-14519)

References

Affected packages

Ubuntu:14.04:LTS / poppler

Package

Name
poppler

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.24.5-2ubuntu4.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libpoppler44": "0.24.5-2ubuntu4.6",
            "libpoppler-qt5-1": "0.24.5-2ubuntu4.6",
            "libpoppler-glib-doc": "0.24.5-2ubuntu4.6",
            "libpoppler-qt5-dev": "0.24.5-2ubuntu4.6",
            "libpoppler-cpp-dev": "0.24.5-2ubuntu4.6",
            "libpoppler-qt4-4": "0.24.5-2ubuntu4.6",
            "libpoppler-glib8": "0.24.5-2ubuntu4.6",
            "libpoppler-glib-dev": "0.24.5-2ubuntu4.6",
            "libpoppler-qt4-dev": "0.24.5-2ubuntu4.6",
            "libpoppler-cpp0": "0.24.5-2ubuntu4.6",
            "gir1.2-poppler-0.18": "0.24.5-2ubuntu4.6",
            "libpoppler-private-dev": "0.24.5-2ubuntu4.6",
            "libpoppler-dev": "0.24.5-2ubuntu4.6",
            "poppler-utils": "0.24.5-2ubuntu4.6"
        }
    ]
}

Ubuntu:16.04:LTS / poppler

Package

Name
poppler

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.41.0-0ubuntu1.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libpoppler-qt5-1": "0.41.0-0ubuntu1.3",
            "libpoppler-glib-doc": "0.41.0-0ubuntu1.3",
            "libpoppler-qt5-dev": "0.41.0-0ubuntu1.3",
            "libpoppler-cpp-dev": "0.41.0-0ubuntu1.3",
            "libpoppler-qt4-4": "0.41.0-0ubuntu1.3",
            "libpoppler-glib8": "0.41.0-0ubuntu1.3",
            "libpoppler-glib-dev": "0.41.0-0ubuntu1.3",
            "libpoppler-qt4-dev": "0.41.0-0ubuntu1.3",
            "libpoppler-cpp0": "0.41.0-0ubuntu1.3",
            "libpoppler58": "0.41.0-0ubuntu1.3",
            "gir1.2-poppler-0.18": "0.41.0-0ubuntu1.3",
            "libpoppler-private-dev": "0.41.0-0ubuntu1.3",
            "libpoppler-dev": "0.41.0-0ubuntu1.3",
            "poppler-utils": "0.41.0-0ubuntu1.3"
        }
    ]
}