USN-3440-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3440-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3440-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3440-1
Related
Published
2017-10-06T14:47:11.058898Z
Modified
2017-10-06T14:47:11.058898Z
Summary
poppler vulnerabilities
Details

It was discovered that Poppler incorrectly handled certain files. If a user or automated system were tricked into opening a crafted PDF file, an attacker could cause a denial of service. (CVE-2017-14518, CVE-2017-14520, CVE-2017-14617, CVE-2017-14929, CVE-2017-14975, CVE-2017-14977)

It was discovered that Poppler incorrectly handled certain files. If a user or automated system were tricked into opening a crafted PDF file, an attacker could cause a denial of service. This issue only affected Ubuntu 17.04 and 16.04. (CVE-2017-14926, CVE-2017-14928)

Alberto Garcia, Francisco Oca and Suleman Ali discovered that Poppler incorrectly handled certain files. If a user or automated system were tricked into opening a crafted PDF file, an attacker could cause a denial of service. (CVE-2017-9776)

References

Affected packages

Ubuntu:14.04:LTS / poppler

Package

Name
poppler

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.24.5-2ubuntu4.7

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libpoppler44": "0.24.5-2ubuntu4.7",
            "libpoppler-qt5-1": "0.24.5-2ubuntu4.7",
            "libpoppler-glib-doc": "0.24.5-2ubuntu4.7",
            "libpoppler-qt5-dev": "0.24.5-2ubuntu4.7",
            "libpoppler-cpp-dev": "0.24.5-2ubuntu4.7",
            "libpoppler-qt4-4": "0.24.5-2ubuntu4.7",
            "libpoppler-glib8": "0.24.5-2ubuntu4.7",
            "libpoppler-glib-dev": "0.24.5-2ubuntu4.7",
            "libpoppler-qt4-dev": "0.24.5-2ubuntu4.7",
            "libpoppler-cpp0": "0.24.5-2ubuntu4.7",
            "gir1.2-poppler-0.18": "0.24.5-2ubuntu4.7",
            "libpoppler-private-dev": "0.24.5-2ubuntu4.7",
            "libpoppler-dev": "0.24.5-2ubuntu4.7",
            "poppler-utils": "0.24.5-2ubuntu4.7"
        }
    ]
}

Ubuntu:16.04:LTS / poppler

Package

Name
poppler

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.41.0-0ubuntu1.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libpoppler-qt5-1": "0.41.0-0ubuntu1.4",
            "libpoppler-glib-doc": "0.41.0-0ubuntu1.4",
            "libpoppler-qt5-dev": "0.41.0-0ubuntu1.4",
            "libpoppler-cpp-dev": "0.41.0-0ubuntu1.4",
            "libpoppler-qt4-4": "0.41.0-0ubuntu1.4",
            "libpoppler-glib8": "0.41.0-0ubuntu1.4",
            "libpoppler-glib-dev": "0.41.0-0ubuntu1.4",
            "libpoppler-qt4-dev": "0.41.0-0ubuntu1.4",
            "libpoppler-cpp0": "0.41.0-0ubuntu1.4",
            "libpoppler58": "0.41.0-0ubuntu1.4",
            "gir1.2-poppler-0.18": "0.41.0-0ubuntu1.4",
            "libpoppler-private-dev": "0.41.0-0ubuntu1.4",
            "libpoppler-dev": "0.41.0-0ubuntu1.4",
            "poppler-utils": "0.41.0-0ubuntu1.4"
        }
    ]
}