USN-3441-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3441-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3441-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3441-1
Related
Published
2017-10-10T12:54:33.773269Z
Modified
2017-10-10T12:54:33.773269Z
Summary
curl vulnerabilities
Details

Daniel Stenberg discovered that curl incorrectly handled large floating point output. A remote attacker could use this issue to cause curl to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2016-9586)

Even Rouault discovered that curl incorrectly handled large file names when doing TFTP transfers. A remote attacker could use this issue to cause curl to crash, resulting in a denial of service, or possibly obtain sensitive memory contents. (CVE-2017-1000100)

Brian Carpenter and Yongji Ouyang discovered that curl incorrectly handled numerical range globbing. A remote attacker could use this issue to cause curl to crash, resulting in a denial of service, or possibly obtain sensitive memory contents. (CVE-2017-1000101)

Max Dymond discovered that curl incorrectly handled FTP PWD responses. A remote attacker could use this issue to cause curl to crash, resulting in a denial of service. (CVE-2017-1000254)

Brian Carpenter discovered that curl incorrectly handled the --write-out command line option. A local attacker could possibly use this issue to obtain sensitive memory contents. (CVE-2017-7407)

References

Affected packages

Ubuntu:14.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.35.0-1ubuntu2.11

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "curl-udeb": "7.35.0-1ubuntu2.11",
            "libcurl3-udeb": "7.35.0-1ubuntu2.11",
            "curl": "7.35.0-1ubuntu2.11",
            "libcurl3": "7.35.0-1ubuntu2.11",
            "libcurl4-gnutls-dev": "7.35.0-1ubuntu2.11",
            "libcurl3-gnutls": "7.35.0-1ubuntu2.11",
            "libcurl4-doc": "7.35.0-1ubuntu2.11",
            "libcurl3-nss": "7.35.0-1ubuntu2.11",
            "libcurl4-nss-dev": "7.35.0-1ubuntu2.11",
            "libcurl4-openssl-dev": "7.35.0-1ubuntu2.11"
        }
    ]
}

Ubuntu:16.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.47.0-1ubuntu2.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "curl": "7.47.0-1ubuntu2.3",
            "libcurl3": "7.47.0-1ubuntu2.3",
            "libcurl4-gnutls-dev": "7.47.0-1ubuntu2.3",
            "libcurl3-gnutls": "7.47.0-1ubuntu2.3",
            "libcurl4-doc": "7.47.0-1ubuntu2.3",
            "libcurl3-nss": "7.47.0-1ubuntu2.3",
            "libcurl4-nss-dev": "7.47.0-1ubuntu2.3",
            "libcurl4-openssl-dev": "7.47.0-1ubuntu2.3"
        }
    ]
}