USN-3498-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3498-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3498-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3498-1
Related
Published
2017-11-29T13:19:11.897011Z
Modified
2017-11-29T13:19:11.897011Z
Summary
curl vulnerabilities
Details

Alex Nichols discovered that curl incorrectly handled NTLM authentication credentials. A remote attacker could use this issue to cause curl to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 16.04 LTS, Ubuntu 17.04 and Ubuntu 17.10. (CVE-2017-8816)

It was discovered that curl incorrectly handled FTP wildcard matching. A remote attacker could use this issue to cause curl to crash, resulting in a denial of service, or possibly obtain sensitive information. (CVE-2017-8817)

References

Affected packages

Ubuntu:14.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.35.0-1ubuntu2.13

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "curl-udeb": "7.35.0-1ubuntu2.13",
            "libcurl3-udeb": "7.35.0-1ubuntu2.13",
            "curl": "7.35.0-1ubuntu2.13",
            "libcurl3": "7.35.0-1ubuntu2.13",
            "libcurl4-gnutls-dev": "7.35.0-1ubuntu2.13",
            "libcurl3-gnutls": "7.35.0-1ubuntu2.13",
            "libcurl4-doc": "7.35.0-1ubuntu2.13",
            "libcurl3-nss": "7.35.0-1ubuntu2.13",
            "libcurl4-nss-dev": "7.35.0-1ubuntu2.13",
            "libcurl4-openssl-dev": "7.35.0-1ubuntu2.13"
        }
    ]
}

Ubuntu:16.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.47.0-1ubuntu2.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "curl": "7.47.0-1ubuntu2.5",
            "libcurl3": "7.47.0-1ubuntu2.5",
            "libcurl4-gnutls-dev": "7.47.0-1ubuntu2.5",
            "libcurl3-gnutls": "7.47.0-1ubuntu2.5",
            "libcurl4-doc": "7.47.0-1ubuntu2.5",
            "libcurl3-nss": "7.47.0-1ubuntu2.5",
            "libcurl4-nss-dev": "7.47.0-1ubuntu2.5",
            "libcurl4-openssl-dev": "7.47.0-1ubuntu2.5"
        }
    ]
}