USN-3509-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-3509-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3509-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3509-2
Related
  • CVE-2017-1000405
  • CVE-2017-12193
  • CVE-2017-16643
  • CVE-2017-16939
Published
2017-12-07T23:34:04.803123Z
Modified
2017-12-07T23:34:04.803123Z
Summary
linux-lts-xenial, linux-aws vulnerabilities
Details

USN-3509-1 fixed vulnerabilities in the Linux kernel for Ubuntu 16.04 LTS. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 16.04 LTS for Ubuntu 14.04 LTS.

Mohamed Ghannam discovered that a use-after-free vulnerability existed in the Netlink subsystem (XFRM) in the Linux kernel. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2017-16939)

It was discovered that the Linux kernel did not properly handle copy-on- write of transparent huge pages. A local attacker could use this to cause a denial of service (application crashes) or possibly gain administrative privileges. (CVE-2017-1000405)

Fan Wu, Haoran Qiu, and Shixiong Zhao discovered that the associative array implementation in the Linux kernel sometimes did not properly handle adding a new entry. A local attacker could use this to cause a denial of service (system crash). (CVE-2017-12193)

Andrey Konovalov discovered an out-of-bounds read in the GTCO digitizer USB driver for the Linux kernel. A physically proximate attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2017-16643)

References

Affected packages

Ubuntu:14.04:LTS / linux-lts-xenial

Package

Name
linux-lts-xenial

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-103.126~14.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.4.0-103-lowlatency": "4.4.0-103.126~14.04.1",
            "linux-image-4.4.0-103-powerpc-smp": "4.4.0-103.126~14.04.1",
            "linux-image-4.4.0-103-powerpc64-smp": "4.4.0-103.126~14.04.1",
            "linux-image-4.4.0-103-powerpc64-emb": "4.4.0-103.126~14.04.1",
            "linux-image-4.4.0-103-generic": "4.4.0-103.126~14.04.1",
            "linux-image-4.4.0-103-powerpc-e500mc": "4.4.0-103.126~14.04.1",
            "linux-image-extra-4.4.0-103-generic": "4.4.0-103.126~14.04.1",
            "linux-image-4.4.0-103-generic-lpae": "4.4.0-103.126~14.04.1"
        }
    ]
}

Ubuntu:14.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-1005.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.4.0-1005-aws": "4.4.0-1005.5"
        }
    ]
}