USN-3515-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3515-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3515-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3515-1
Related
Published
2018-01-04T15:49:50.838187Z
Modified
2018-01-04T15:49:50.838187Z
Summary
ruby1.9.1, ruby2.0, ruby2.3 vulnerability
Details

It was discovered that Ruby allows FTP command injection. An attacker could use this to cause arbitrary command execution.

References

Affected packages

Ubuntu:14.04:LTS / ruby1.9.1

Package

Name
ruby1.9.1

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.9.3.484-2ubuntu1.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ri1.9.1": "1.9.3.484-2ubuntu1.6",
            "libtcltk-ruby1.9.1": "1.9.3.484-2ubuntu1.6",
            "libruby1.9.1": "1.9.3.484-2ubuntu1.6",
            "ruby1.9.1-dev": "1.9.3.484-2ubuntu1.6",
            "ruby1.9.3": "1.9.3.484-2ubuntu1.6",
            "ruby1.9.1-full": "1.9.3.484-2ubuntu1.6",
            "ruby1.9.1-examples": "1.9.3.484-2ubuntu1.6",
            "ruby1.9.1": "1.9.3.484-2ubuntu1.6"
        }
    ]
}

Ubuntu:14.04:LTS / ruby2.0

Package

Name
ruby2.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.0.0.484-1ubuntu2.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ruby2.0-tcltk": "2.0.0.484-1ubuntu2.5",
            "ruby2.0": "2.0.0.484-1ubuntu2.5",
            "libruby2.0": "2.0.0.484-1ubuntu2.5",
            "ruby2.0-doc": "2.0.0.484-1ubuntu2.5",
            "ruby2.0-dev": "2.0.0.484-1ubuntu2.5"
        }
    ]
}

Ubuntu:16.04:LTS / ruby2.3

Package

Name
ruby2.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.1-2~16.04.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ruby2.3-doc": "2.3.1-2~16.04.4",
            "ruby2.3-dev": "2.3.1-2~16.04.4",
            "ruby2.3-tcltk": "2.3.1-2~16.04.4",
            "libruby2.3": "2.3.1-2~16.04.4",
            "ruby2.3": "2.3.1-2~16.04.4"
        }
    ]
}