USN-3516-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3516-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3516-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3516-1
Related
Published
2018-01-05T21:18:31.759862Z
Modified
2018-01-05T21:18:31.759862Z
Summary
firefox vulnerabilities
Details

It was discovered that speculative execution performed by modern CPUs could leak information through a timing side-channel attack, and that this could be exploited in web browser JavaScript engines. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to obtain sensitive information from other domains, bypassing same-origin restrictions. (CVE-2017-5715, CVE-2017-5753, CVE-2017-5754).

References

Affected packages

Ubuntu:14.04:LTS / firefox

Package

Name
firefox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
57.0.4+build1-0ubuntu0.14.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firefox-locale-sl": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-nl": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-kn": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-gl": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-fy": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-kk": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-km": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-or": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-az": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-lt": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-hy": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-eo": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-sv": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-testsuite": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-sr": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-is": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ca": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-uk": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ga": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-it": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ja": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-lg": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ms": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-zh-hans": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-mozsymbols": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ko": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-hr": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-mai": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-nb": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-dev": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-vi": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-he": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-sw": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-el": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-oc": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-xh": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-nn": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ar": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-csb": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-cs": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-gn": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-hsb": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-zu": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-my": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ro": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-globalmenu": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-nso": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-af": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-sk": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-si": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-cy": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-fa": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-cak": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-sq": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-en": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-tr": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-br": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-et": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ast": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-th": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-da": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-fi": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ku": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-mn": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ru": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-mk": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-bg": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-hu": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-gu": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-bn": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-kab": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ml": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-an": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-be": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-eu": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-fr": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-pa": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-as": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ta": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-pl": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-bs": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-te": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-id": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ka": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-lv": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-gd": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-uz": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-zh-hant": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-hi": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-es": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-de": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-mr": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-pt": "57.0.4+build1-0ubuntu0.14.04.1",
            "firefox-locale-ur": "57.0.4+build1-0ubuntu0.14.04.1"
        }
    ]
}

Ubuntu:16.04:LTS / firefox

Package

Name
firefox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
57.0.4+build1-0ubuntu0.16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firefox-locale-sl": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-nl": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-kn": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-gl": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-fy": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-kk": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-km": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-or": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-az": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-lt": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-hy": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-eo": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-sv": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-testsuite": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-sr": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-is": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ca": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-uk": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ga": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-it": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ja": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-lg": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ms": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-zh-hans": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-mozsymbols": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ko": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-hr": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-mai": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-nb": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-dev": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-vi": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-he": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-sw": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-el": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-oc": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-xh": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-nn": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ar": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-csb": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-cs": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-gn": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-hsb": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-zu": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-my": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ro": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-globalmenu": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-nso": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-af": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-sk": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-si": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-cy": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-fa": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-cak": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-sq": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-en": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-tr": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-br": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-et": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ast": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-th": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-da": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-fi": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ku": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-mn": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ru": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-mk": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-bg": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-hu": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-gu": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-bn": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-kab": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ml": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-an": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-be": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-eu": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-fr": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-pa": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-as": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ta": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-pl": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-bs": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-te": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-id": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ka": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-lv": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-gd": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-uz": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-zh-hant": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-hi": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-es": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-de": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-mr": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-pt": "57.0.4+build1-0ubuntu0.16.04.1",
            "firefox-locale-ur": "57.0.4+build1-0ubuntu0.16.04.1"
        }
    ]
}