USN-3530-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3530-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3530-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3530-1
Related
Published
2018-01-11T13:59:55.959458Z
Modified
2018-01-11T13:59:55.959458Z
Summary
webkit2gtk vulnerabilities
Details

It was discovered that speculative execution performed by modern CPUs could leak information through a timing side-channel attack, and that this could be exploited in web browser JavaScript engines. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to obtain sensitive information from other domains, bypassing same-origin restrictions. (CVE-2017-5753, CVE-2017-5715)

References

Affected packages

Ubuntu:16.04:LTS / webkit2gtk

Package

Name
webkit2gtk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.18.5-0ubuntu0.16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "gir1.2-webkit2-4.0": "2.18.5-0ubuntu0.16.04.1",
            "libwebkit2gtk-4.0-dev": "2.18.5-0ubuntu0.16.04.1",
            "libjavascriptcoregtk-4.0-dev": "2.18.5-0ubuntu0.16.04.1",
            "gir1.2-javascriptcoregtk-4.0": "2.18.5-0ubuntu0.16.04.1",
            "libwebkit2gtk-4.0-37-gtk2": "2.18.5-0ubuntu0.16.04.1",
            "libwebkit2gtk-4.0-37": "2.18.5-0ubuntu0.16.04.1",
            "libjavascriptcoregtk-4.0-18": "2.18.5-0ubuntu0.16.04.1",
            "libwebkit2gtk-4.0-doc": "2.18.5-0ubuntu0.16.04.1",
            "libjavascriptcoregtk-4.0-bin": "2.18.5-0ubuntu0.16.04.1"
        }
    ]
}