USN-3552-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3552-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3552-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3552-1
Related
  • CVE-2018-5124
Published
2018-01-31T16:53:56.452511Z
Modified
2018-01-31T16:53:56.452511Z
Summary
firefox vulnerability
Details

Johann Hofmann discovered that HTML fragments created for chrome-privileged documents were not properly sanitized. An attacker could exploit this to execute arbitrary code. (CVE-2018-5124)

References

Affected packages

Ubuntu:14.04:LTS / firefox

Package

Name
firefox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
58.0.1+build1-0ubuntu0.14.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firefox-locale-sl": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-nl": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-kn": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-gl": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-fy": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-kk": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-km": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-or": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-az": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-lt": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-hy": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-eo": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-sv": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-testsuite": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-sr": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-is": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ca": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-uk": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ne": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ga": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-it": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ja": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-lg": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ms": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-zh-hans": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-mozsymbols": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ko": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-hr": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-mai": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-nb": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-dev": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-vi": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-he": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-sw": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-el": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-oc": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-xh": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-nn": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ar": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-csb": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-cs": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-gn": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-hsb": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-zu": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-my": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ro": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-globalmenu": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-nso": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-af": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-sk": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-si": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-cy": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-fa": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-cak": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-sq": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-en": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-tr": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-br": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-et": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ast": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-th": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-da": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-fi": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ku": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-mn": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ru": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-mk": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-bg": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-hu": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-gu": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-bn": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-kab": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ml": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-an": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-be": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-eu": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-fr": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-pa": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-as": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ta": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-pl": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-bs": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-te": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-id": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ka": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-lv": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-gd": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-uz": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-zh-hant": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-hi": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-es": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-de": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-mr": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-pt": "58.0.1+build1-0ubuntu0.14.04.1",
            "firefox-locale-ur": "58.0.1+build1-0ubuntu0.14.04.1"
        }
    ]
}

Ubuntu:16.04:LTS / firefox

Package

Name
firefox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
58.0.1+build1-0ubuntu0.16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firefox-locale-sl": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-nl": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-kn": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-gl": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-fy": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-kk": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-km": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-or": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-az": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-lt": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-hy": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-eo": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-sv": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-testsuite": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-sr": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-is": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ca": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-uk": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ne": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ga": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-it": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ja": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-lg": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ms": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-zh-hans": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-mozsymbols": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ko": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-hr": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-mai": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-nb": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-dev": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-vi": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-he": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-sw": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-el": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-oc": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-xh": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-nn": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ar": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-csb": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-cs": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-gn": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-hsb": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-zu": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-my": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ro": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-globalmenu": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-nso": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-af": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-sk": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-si": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-cy": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-fa": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-cak": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-sq": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-en": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-tr": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-br": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-et": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ast": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-th": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-da": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-fi": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ku": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-mn": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ru": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-mk": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-bg": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-hu": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-gu": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-bn": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-kab": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ml": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-an": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-be": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-eu": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-fr": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-pa": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-as": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ta": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-pl": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-bs": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-te": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-id": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ka": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-lv": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-gd": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-uz": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-zh-hant": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-hi": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-es": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-de": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-mr": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-pt": "58.0.1+build1-0ubuntu0.16.04.1",
            "firefox-locale-ur": "58.0.1+build1-0ubuntu0.16.04.1"
        }
    ]
}