USN-3594-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3594-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3594-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3594-1
Related
Published
2018-03-09T09:02:37.847232Z
Modified
2018-03-09T09:02:37.847232Z
Summary
linux vulnerability
Details

USN-3542-1 mitigated CVE-2017-5715 (Spectre Variant 2) for the amd64 architecture in Ubuntu 14.04 LTS. This update provides the compiler-based retpoline kernel mitigation for the amd64 and i386 architectures. Original advisory details:

Jann Horn discovered that microprocessors utilizing speculative execution and branch prediction may allow unauthorized memory reads via sidechannel attacks. This flaw is known as Spectre. A local attacker could use this to expose sensitive information, including kernel memory. (CVE-2017-5715)

References

Affected packages

Ubuntu:14.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.13.0-143.192

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-3.13.0-143-lowlatency": "3.13.0-143.192",
            "linux-image-3.13.0-143-generic": "3.13.0-143.192",
            "linux-image-extra-3.13.0-143-generic": "3.13.0-143.192",
            "linux-image-3.13.0-143-generic-lpae": "3.13.0-143.192",
            "linux-image-3.13.0-143-powerpc-e500mc": "3.13.0-143.192",
            "linux-image-3.13.0-143-powerpc-smp": "3.13.0-143.192",
            "linux-image-3.13.0-143-powerpc-e500": "3.13.0-143.192",
            "linux-image-3.13.0-143-powerpc64-emb": "3.13.0-143.192",
            "linux-image-3.13.0-143-powerpc64-smp": "3.13.0-143.192"
        }
    ]
}