USN-3608-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3608-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3608-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3608-1
Related
Published
2018-03-27T14:16:39.991865Z
Modified
2018-03-27T14:16:39.991865Z
Summary
zsh vulnerabilities
Details

Richard Maciel Costa discovered that Zsh incorrectly handled certain inputs. An attacker could possibly use this to cause a denial of service. (CVE-2018-1071)

It was discovered that Zsh incorrectly handled certain files. An attacker could possibly use this to execute arbitrary code. (CVE-2018-1083)

References

Affected packages

Ubuntu:14.04:LTS / zsh

Package

Name
zsh

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.0.2-3ubuntu6.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "zsh-static": "5.0.2-3ubuntu6.2",
            "zsh": "5.0.2-3ubuntu6.2",
            "zsh-common": "5.0.2-3ubuntu6.2",
            "zsh-dev": "5.0.2-3ubuntu6.2",
            "zsh-doc": "5.0.2-3ubuntu6.2",
            "zsh-beta-doc": "5.0.2-3ubuntu6.2",
            "zsh-beta": "5.0.2-3ubuntu6.2"
        }
    ]
}

Ubuntu:16.04:LTS / zsh

Package

Name
zsh

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.1.1-1ubuntu2.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "zsh-dev": "5.1.1-1ubuntu2.2",
            "zsh-static": "5.1.1-1ubuntu2.2",
            "zsh-doc": "5.1.1-1ubuntu2.2",
            "zsh": "5.1.1-1ubuntu2.2",
            "zsh-common": "5.1.1-1ubuntu2.2"
        }
    ]
}