USN-3622-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3622-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3622-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3622-1
Related
Published
2018-04-09T16:42:29.972207Z
Modified
2018-04-09T16:42:29.972207Z
Summary
wayland vulnerability
Details

It was discovered that the Wayland Xcursor support incorrectly handled certain files. An attacker could use these issues to cause Wayland to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:14.04:LTS / wayland

Package

Name
wayland

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.4.0-1ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libwayland-client0": "1.4.0-1ubuntu1.1",
            "libwayland-cursor0": "1.4.0-1ubuntu1.1",
            "libwayland-dev": "1.4.0-1ubuntu1.1",
            "libwayland-server0": "1.4.0-1ubuntu1.1",
            "libwayland0": "1.4.0-1ubuntu1.1"
        }
    ]
}

Ubuntu:16.04:LTS / wayland

Package

Name
wayland

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.12.0-1~ubuntu16.04.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libwayland-bin": "1.12.0-1~ubuntu16.04.3",
            "libwayland-doc": "1.12.0-1~ubuntu16.04.3",
            "libwayland-cursor0": "1.12.0-1~ubuntu16.04.3",
            "libwayland-dev": "1.12.0-1~ubuntu16.04.3",
            "libwayland-server0": "1.12.0-1~ubuntu16.04.3",
            "libwayland-client0": "1.12.0-1~ubuntu16.04.3"
        }
    ]
}