USN-3630-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-3630-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3630-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3630-2
Related
Published
2018-04-24T02:27:18.470833Z
Modified
2018-04-24T02:27:18.470833Z
Summary
linux-hwe, linux-gcp, linux-oem vulnerability
Details

USN-3630-1 fixed a vulnerability in the Linux kernel for Ubuntu 17.10. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 17.10 for Ubuntu 16.04 LTS.

It was discovered that the Broadcom UniMAC MDIO bus controller driver in the Linux kernel did not properly validate device resources. A local attacker could use this to cause a denial of service (system crash).

References

Affected packages

Ubuntu:16.04:LTS / linux-hwe

Package

Name
linux-hwe

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.13.0-39.44~16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.13.0-39-generic": "4.13.0-39.44~16.04.1",
            "linux-image-4.13.0-39-generic-lpae": "4.13.0-39.44~16.04.1",
            "linux-image-4.13.0-39-lowlatency": "4.13.0-39.44~16.04.1",
            "linux-image-extra-4.13.0-39-generic": "4.13.0-39.44~16.04.1"
        }
    ]
}

Ubuntu:16.04:LTS / linux-oem

Package

Name
linux-oem

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.13.0-1024.27

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.13.0-1024-oem": "4.13.0-1024.27"
        }
    ]
}

Ubuntu:16.04:LTS / linux-gcp

Package

Name
linux-gcp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.13.0-1013.17

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-extra-4.13.0-1013-gcp": "4.13.0-1013.17",
            "linux-image-4.13.0-1013-gcp": "4.13.0-1013.17"
        }
    ]
}