USN-3681-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3681-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3681-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3681-1
Related
Published
2018-06-12T11:40:14.599634Z
Modified
2018-06-12T11:40:14.599634Z
Summary
imagemagick vulnerabilities
Details

It was discovered that ImageMagick incorrectly handled certain malformed image files. If a user or automated system using ImageMagick were tricked into opening a specially crafted image, an attacker could exploit this to cause a denial of service or possibly execute code with the privileges of the user invoking the program.

References

Affected packages

Ubuntu:18.04:LTS / imagemagick

Package

Name
imagemagick

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8:6.9.7.4+dfsg-16ubuntu6.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "imagemagick-common": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickcore-6.q16hdri-3": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libimage-magick-q16-perl": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libimage-magick-q16hdri-perl": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagick++-dev": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "imagemagick-6-common": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickcore-6.q16-3": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libimage-magick-perl": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickwand-6.q16-dev": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "imagemagick-6-doc": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickwand-dev": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagick++-6.q16hdri-dev": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickcore-6.q16-dev": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickwand-6.q16-3": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "perlmagick": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickcore-6.q16hdri-dev": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickwand-6-headers": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagick++-6.q16hdri-7": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagick++-6-headers": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickcore-6.q16hdri-3-extra": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickwand-6.q16hdri-dev": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagick++-6.q16-7": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickcore-6-headers": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "imagemagick-doc": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickwand-6.q16hdri-3": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "imagemagick": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickcore-6-arch-config": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "imagemagick-6.q16": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickcore-6.q16-3-extra": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagick++-6.q16-dev": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "imagemagick-6.q16hdri": "8:6.9.7.4+dfsg-16ubuntu6.2",
            "libmagickcore-dev": "8:6.9.7.4+dfsg-16ubuntu6.2"
        }
    ]
}

Ubuntu:14.04:LTS / imagemagick

Package

Name
imagemagick

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8:6.7.7.10-6ubuntu3.11

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libmagickcore5-extra": "8:6.7.7.10-6ubuntu3.11",
            "libmagickcore5": "8:6.7.7.10-6ubuntu3.11",
            "libmagickcore-dev": "8:6.7.7.10-6ubuntu3.11",
            "imagemagick-doc": "8:6.7.7.10-6ubuntu3.11",
            "libmagick++5": "8:6.7.7.10-6ubuntu3.11",
            "libmagick++-dev": "8:6.7.7.10-6ubuntu3.11",
            "perlmagick": "8:6.7.7.10-6ubuntu3.11",
            "imagemagick": "8:6.7.7.10-6ubuntu3.11",
            "libmagickwand5": "8:6.7.7.10-6ubuntu3.11",
            "libmagickwand-dev": "8:6.7.7.10-6ubuntu3.11",
            "imagemagick-common": "8:6.7.7.10-6ubuntu3.11"
        }
    ]
}

Ubuntu:16.04:LTS / imagemagick

Package

Name
imagemagick

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8:6.8.9.9-7ubuntu5.11

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libmagickcore-6.q16-2": "8:6.8.9.9-7ubuntu5.11",
            "imagemagick-common": "8:6.8.9.9-7ubuntu5.11",
            "libimage-magick-q16-perl": "8:6.8.9.9-7ubuntu5.11",
            "imagemagick-doc": "8:6.8.9.9-7ubuntu5.11",
            "libmagick++-6.q16-5v5": "8:6.8.9.9-7ubuntu5.11",
            "libmagick++-dev": "8:6.8.9.9-7ubuntu5.11",
            "libmagickwand-6.q16-2": "8:6.8.9.9-7ubuntu5.11",
            "libimage-magick-perl": "8:6.8.9.9-7ubuntu5.11",
            "imagemagick": "8:6.8.9.9-7ubuntu5.11",
            "libmagickwand-6.q16-dev": "8:6.8.9.9-7ubuntu5.11",
            "libmagickcore-6-arch-config": "8:6.8.9.9-7ubuntu5.11",
            "imagemagick-6.q16": "8:6.8.9.9-7ubuntu5.11",
            "libmagickcore-6.q16-2-extra": "8:6.8.9.9-7ubuntu5.11",
            "libmagickcore-6.q16-dev": "8:6.8.9.9-7ubuntu5.11",
            "libmagickwand-dev": "8:6.8.9.9-7ubuntu5.11",
            "libmagick++-6.q16-dev": "8:6.8.9.9-7ubuntu5.11",
            "perlmagick": "8:6.8.9.9-7ubuntu5.11",
            "libmagickwand-6-headers": "8:6.8.9.9-7ubuntu5.11",
            "libmagickcore-6-headers": "8:6.8.9.9-7ubuntu5.11",
            "libmagick++-6-headers": "8:6.8.9.9-7ubuntu5.11",
            "libmagickcore-dev": "8:6.8.9.9-7ubuntu5.11"
        }
    ]
}