USN-3684-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3684-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3684-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3684-1
Related
Published
2018-06-13T16:09:13.722858Z
Modified
2018-06-13T16:09:13.722858Z
Summary
perl vulnerability
Details

It was discovered that Perl incorrectly handled certain archive files. An attacker could possibly use this to overwrite arbitrary files.

References

Affected packages

Ubuntu:18.04:LTS / perl

Package

Name
perl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.26.1-6ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "perl-debug": "5.26.1-6ubuntu0.1",
            "perl": "5.26.1-6ubuntu0.1",
            "libperl-dev": "5.26.1-6ubuntu0.1",
            "libperl5.26": "5.26.1-6ubuntu0.1",
            "perl-doc": "5.26.1-6ubuntu0.1",
            "perl-modules-5.26": "5.26.1-6ubuntu0.1",
            "perl-base": "5.26.1-6ubuntu0.1"
        }
    ]
}

Ubuntu:14.04:LTS / perl

Package

Name
perl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.18.2-2ubuntu1.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "perl-debug": "5.18.2-2ubuntu1.6",
            "perl": "5.18.2-2ubuntu1.6",
            "perl-modules": "5.18.2-2ubuntu1.6",
            "libperl-dev": "5.18.2-2ubuntu1.6",
            "libperl5.18": "5.18.2-2ubuntu1.6",
            "libcgi-fast-perl": "5.18.2-2ubuntu1.6",
            "perl-doc": "5.18.2-2ubuntu1.6",
            "perl-base": "5.18.2-2ubuntu1.6"
        }
    ]
}

Ubuntu:16.04:LTS / perl

Package

Name
perl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.22.1-9ubuntu0.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "perl-debug": "5.22.1-9ubuntu0.5",
            "perl-modules-5.22": "5.22.1-9ubuntu0.5",
            "perl": "5.22.1-9ubuntu0.5",
            "libperl-dev": "5.22.1-9ubuntu0.5",
            "libperl5.22": "5.22.1-9ubuntu0.5",
            "perl-doc": "5.22.1-9ubuntu0.5",
            "perl-base": "5.22.1-9ubuntu0.5"
        }
    ]
}