USN-3692-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3692-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3692-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3692-1
Related
Published
2018-06-26T12:08:09.277793Z
Modified
2018-06-26T12:08:09.277793Z
Summary
openssl, openssl1.0 vulnerabilities
Details

Keegan Ryan discovered that OpenSSL incorrectly handled ECDSA key generation. An attacker could possibly use this issue to perform a cache-timing attack and recover private ECDSA keys. (CVE-2018-0495)

Guido Vranken discovered that OpenSSL incorrectly handled very large prime values during a key agreement. A remote attacker could possibly use this issue to consume resources, leading to a denial of service. (CVE-2018-0732)

Alejandro Cabrera Aldaya, Billy Brumley, Cesar Pereida Garcia and Luis Manuel Alvarez Tapia discovered that OpenSSL incorrectly handled RSA key generation. An attacker could possibly use this issue to perform a cache-timing attack and recover private RSA keys. (CVE-2018-0737)

References

Affected packages

Ubuntu:18.04:LTS / openssl1.0

Package

Name
openssl1.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.2n-1ubuntu5.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl1.0-dev": "1.0.2n-1ubuntu5.1",
            "openssl1.0": "1.0.2n-1ubuntu5.1",
            "libssl1.0.0-udeb": "1.0.2n-1ubuntu5.1",
            "libssl1.0.0": "1.0.2n-1ubuntu5.1",
            "libcrypto1.0.0-udeb": "1.0.2n-1ubuntu5.1"
        }
    ]
}

Ubuntu:18.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.0g-2ubuntu4.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl-dev": "1.1.0g-2ubuntu4.1",
            "openssl": "1.1.0g-2ubuntu4.1",
            "libcrypto1.1-udeb": "1.1.0g-2ubuntu4.1",
            "libssl-doc": "1.1.0g-2ubuntu4.1",
            "libssl1.1": "1.1.0g-2ubuntu4.1",
            "libssl1.1-udeb": "1.1.0g-2ubuntu4.1"
        }
    ]
}

Ubuntu:14.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.1f-1ubuntu2.26

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl-dev": "1.0.1f-1ubuntu2.26",
            "openssl": "1.0.1f-1ubuntu2.26",
            "libssl-doc": "1.0.1f-1ubuntu2.26",
            "libssl1.0.0-udeb": "1.0.1f-1ubuntu2.26",
            "libssl1.0.0": "1.0.1f-1ubuntu2.26",
            "libcrypto1.0.0-udeb": "1.0.1f-1ubuntu2.26"
        }
    ]
}

Ubuntu:16.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.2g-1ubuntu4.13

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl-dev": "1.0.2g-1ubuntu4.13",
            "openssl": "1.0.2g-1ubuntu4.13",
            "libssl-doc": "1.0.2g-1ubuntu4.13",
            "libssl1.0.0-udeb": "1.0.2g-1ubuntu4.13",
            "libssl1.0.0": "1.0.2g-1ubuntu4.13",
            "libcrypto1.0.0-udeb": "1.0.2g-1ubuntu4.13"
        }
    ]
}